Bug 1272181 - Connect in fullscreen mode is not working with spice-xpi
Summary: Connect in fullscreen mode is not working with spice-xpi
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.6.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ovirt-3.6.1
: ---
Assignee: Tomas Jelinek
QA Contact: Pavel Stehlik
URL:
Whiteboard:
: 1274410 (view as bug list)
Depends On:
Blocks: 1274410
TreeView+ depends on / blocked
 
Reported: 2015-10-15 16:36 UTC by Vaclav Ehrlich
Modified: 2016-10-04 04:03 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1274410 (view as bug list)
Environment:
Last Closed: 2016-04-20 01:34:02 UTC
oVirt Team: Virt
Target Upstream Version:


Attachments (Terms of Use)
spice-xpi log (3.02 KB, text/plain)
2015-10-15 16:37 UTC, Vaclav Ehrlich
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 47856 0 None None None Never
oVirt gerrit 47963 0 ovirt-engine-3.6 MERGED userportal,webadmin: boolean params not always parsed well for browser plugins Never

Description Vaclav Ehrlich 2015-10-15 16:36:27 UTC
Description of problem:
When try to connect to VM with 'Open in Full Screen' and 'Browser plugin' options set up, only windowed VM is opened.
Native client Console Invocation works as expected.

Version-Release number of selected component (if applicable):
spice-xpi-2.8-8.el7
firefox-38.2.1-1
virt-viewer-2.0-6

How reproducible:
Always

Steps to Reproduce:
1.Open browser, connect to RHEVM, select VM
2.Click on Edit Console Options adn enable 'Open in Full Screen' option and click on 'OK' button
3.Click on Console button to connect to VM

Actual results:
remote-viewer starts in window mode

Expected results:
remote-viewer starts in Fullscreen mode

Additional info:
Client RHEL7.2 64
Guest Windows7 64

When you try the same with 'Native client' as Console Invocation, rv is opened in full Screen.

Comment 1 Vaclav Ehrlich 2015-10-15 16:37:19 UTC
Created attachment 1083313 [details]
spice-xpi log

Comment 3 Christophe Fergeau 2015-10-19 15:52:14 UTC
RHEV version is missing... This is working for me in 3.5, failing in 3.6, and working in the test page at https://secure.freedesktop.org/~teuf/test.html (or the one from the spice-xpi package).

Comment 4 Christophe Fergeau 2015-10-19 15:56:51 UTC
Moving bug to RHEV for further investigation (I've been testing with the user portal even though I did not mention this in my previous comment).

Comment 5 Andrei Stepanov 2015-10-22 16:30:16 UTC
Also reproduces on:

Client:
spice-xpi-2.7-27.el6.i686
virt-viewer-2.0-7.el6.i686

Guest:
spice-vdagent-0.14.0-10.el7.x86_64

Rhev-m:
rhevm-userportal-3.6.0.1-0.1.el6.noarch
rhevm-webadmin-portal-3.6.0.1-0.1.el6.noarch

Comment 6 Christophe Fergeau 2015-10-22 16:34:00 UTC
If this is a bug in the RHEV user/admin portal, it's expected it will happen with el6 too.

Comment 7 Christophe Fergeau 2015-10-22 16:35:02 UTC
*** Bug 1274410 has been marked as a duplicate of this bug. ***

Comment 8 Andrei Stepanov 2015-10-22 16:35:55 UTC
Bug does _not_ reproduce on the same client with RHEV-M 3.5:

Client:
spice-xpi-2.7-27.el6.i686
virt-viewer-2.0-7.el6.i686

RHEV-M:
rhevm-userportal-3.5.5-0.1.el6ev.noarch
rhevm-webadmin-portal-3.5.5-0.1.el6ev.noarch

Comment 9 Lukas Svaty 2015-11-26 15:05:28 UTC
working with 
spice-xpi-2.8-8.el7.x86_64
virt-viewer-2.0-6.el7.x86_64
rhevm-webadmin-portal-3.6.1-0.2.el6.noarch
rhevm-userportal-3.6.1-0.2.el6.noarch


Note You need to log in before you can comment on or make changes to this bug.