Bug 1272403 - [Tier]: man page of gluster should be updated to list tier commands
[Tier]: man page of gluster should be updated to list tier commands
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: tier (Show other bugs)
3.1
x86_64 Linux
unspecified Severity medium
: ---
: RHGS 3.1.2
Assigned To: Dan Lambright
nchilaka
: ZStream
Depends On: 1272399 1272557
Blocks: 1260783 1260923
  Show dependency treegraph
 
Reported: 2015-10-16 06:36 EDT by Rahul Hinduja
Modified: 2016-09-17 11:38 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1272399
Environment:
Last Closed: 2016-03-01 00:41:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul Hinduja 2015-10-16 06:36:57 EDT
+++ This bug was initially created as a clone of Bug #1272399 +++

Description of problem:
=======================

manual page of gluster should be updated with tier commands like:

tier status,attach, detach etc.


Version-Release number of selected component (if applicable):
=============================================================

glusterfs-3.7.5-0.19.git0f5c3e8.el7.centos.x86_64


How reproducible:
=================

always


Steps to Reproduce:
===================
1. man gluster

Actual results:
===============
Tier information is missing

Expected results:
=================

It should contain tier information
Comment 4 Rahul Hinduja 2015-10-30 06:33:02 EDT
Verified with build: glusterfs-3.7.5-5.el7rhgs.x86_64

man page of gluster is updated with the following tier commands. Moving the bug to verified state. 

# man gluster
:                 :               :               :            :  
:                 :               :               :            :  

  Tier Commands
        volume tier <VOLNAME> attach [<replica COUNT>] <NEW-BRICK>...
              Attach to an existing volume a tier of specified type using the specified bricks.

        volume tier <VOLNAME> status
              Display statistics on data migration between the hot and cold tiers.

        volume tier <VOLNAME> detach start
              Begin  detaching the hot tier from the volume. Data will be moved from the hot tier to
              the cold tier.

        volume tier <VOLNAME> detach commit [force]
              Commit detaching the hot tier from the volume. The volume will revert to its  original
              state before the hot tier was attached.

        volume tier <VOLNAME> detach status
              Check status of data movement from the hot to cold tier.

        volume tier <VOLNAME> detach stop
              Stop detaching the hot tier from the volume.
Comment 6 errata-xmlrpc 2016-03-01 00:41:34 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.