Bug 1272411 - quota: set quota version for files/directories
quota: set quota version for files/directories
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Manikandan
: ZStream
Depends On: 1265200
Blocks: 1277080
  Show dependency treegraph
 
Reported: 2015-10-16 06:54 EDT by Vijaikumar Mallikarjuna
Modified: 2016-06-16 09:40 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1265200
: 1277080 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:40:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-10-19 04:25:47 EDT
REVIEW: http://review.gluster.org/12386 (quota: add version to quota xattrs) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 2 Vijay Bellur 2015-10-19 09:30:33 EDT
REVIEW: http://review.gluster.org/12386 (quota: add version to quota xattrs) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 3 Vijay Bellur 2015-10-20 01:52:56 EDT
REVIEW: http://review.gluster.org/12386 (quota: add version to quota xattrs) posted (#3) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 4 Vijay Bellur 2015-10-21 00:33:06 EDT
REVIEW: http://review.gluster.org/12386 (quota: add version to quota xattrs) posted (#4) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 5 Vijay Bellur 2015-11-02 03:54:44 EST
COMMIT: http://review.gluster.org/12386 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit d90b87eed2fa68df5afcebbc54747e96f6d76cfb
Author: vmallika <vmallika@redhat.com>
Date:   Thu Oct 15 12:41:13 2015 +0530

    quota: add version to quota xattrs
    
    When a quota is disable and the clean-up process terminated
    without completely cleaning-up the quota xattrs.
    Now when quota is enabled again, this can mess-up the accounting
    
    A version number is suffixed for all quota xattrs and this version
    number is specific to marker xaltor, i.e when quota xattrs are
    requested by quotad/client marker will remove the version suffix in the
    key before sending the response
    
    Change-Id: I1ca2c11460645edba0f6b68db70d476d8d26e1eb
    BUG: 1272411
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/12386
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 8 Niels de Vos 2016-06-16 09:40:19 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.