Bug 1277080 - quota: set quota version for files/directories
quota: set quota version for files/directories
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
3.7.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vijaikumar Mallikarjuna
: ZStream
Depends On: 1265200 1272411
Blocks: glusterfs-3.7.6
  Show dependency treegraph
 
Reported: 2015-11-02 04:46 EST by Vijaikumar Mallikarjuna
Modified: 2016-05-11 18:49 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.7.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1272411
Environment:
Last Closed: 2015-11-17 01:01:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-11-02 04:47:07 EST
REVIEW: http://review.gluster.org/12487 (quota: add version to quota xattrs) posted (#1) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 2 Vijay Bellur 2015-11-03 00:03:49 EST
COMMIT: http://review.gluster.org/12487 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit 3d3176958b7da48dbacb1a5a0fedf26322a38297
Author: vmallika <vmallika@redhat.com>
Date:   Thu Oct 15 12:41:13 2015 +0530

    quota: add version to quota xattrs
    
    This is a backport of http://review.gluster.org/#/c/12386/
    
    When a quota is disable and the clean-up process terminated
    without completely cleaning-up the quota xattrs.
    Now when quota is enabled again, this can mess-up the accounting
    
    A version number is suffixed for all quota xattrs and this version
    number is specific to marker xaltor, i.e when quota xattrs are
    requested by quotad/client marker will remove the version suffix in the
    key before sending the response
    
    > Change-Id: I1ca2c11460645edba0f6b68db70d476d8d26e1eb
    > BUG: 1272411
    > Signed-off-by: vmallika <vmallika@redhat.com>
    > Reviewed-on: http://review.gluster.org/12386
    > Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    > Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    
    Change-Id: I67b1b930b28411d76b2d476a4e5250c52aa495a0
    BUG: 1277080
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/12487
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Tested-by: Raghavendra G <rgowdapp@redhat.com>
Comment 3 Raghavendra Talur 2015-11-17 01:01:43 EST
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.6, please open a new bug report.

glusterfs-3.7.6 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-November/024359.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.