Bug 1272538 - beah and a particular task causes excessive logs to be created
beah and a particular task causes excessive logs to be created
Status: CLOSED DUPLICATE of bug 1063647
Product: Beaker
Classification: Community
Component: beah (Show other bugs)
21
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: beaker-dev-list
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-16 12:45 EDT by drohwer
Modified: 2015-10-19 08:28 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-18 18:59:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description drohwer 2015-10-16 12:45:09 EDT
Description of problem:

From a recipe we noticed this:

beah-fwd-backend[4820]: 2015-10-16 10:40:42,907 backend linfo: INFO BackendFactory: Resetting reconnection delay 
beah-beaker-backend[4819]: 2015-06-30 23:45:00,388 backend.twisted emit: ERROR Unhandled Error 

beah-beaker-backend[4819]: Traceback (most recent call last): 
beah-beaker-backend[4819]: File "/usr/bin/beah-beaker-backend", line 9, in <module> 
beah-beaker-backend[4819]: load_entry_point('beah==0.7.9.dev201509141901', 'console_scripts', 'beah-beaker-backend')() 
beah-beaker-backend[4819]: File "/usr/lib/python2.7/site-packages/beah/backends/beakerlc.py", line 2074, in main 
beah-beaker-backend[4819]: debug.runcall(reactor.run) 
beah-beaker-backend[4819]: File "/usr/lib/python2.7/site-packages/beah/core/debug.py", line 11, in runcall 
beah-beaker-backend[4819]: a_callable(*args, **kwargs) 
beah-beaker-backend[4819]: File "/usr/lib64/python2.7/site-packages/twisted/internet/base.py", line 1169, in run 
beah-beaker-backend[4819]: self.mainLoop() 
beah-beaker-backend[4819]: --- <exception caught here> --- 
beah-beaker-backend[4819]: File "/usr/lib64/python2.7/site-packages/twisted/internet/base.py", line 1181, in mainLoop 
beah-beaker-backend[4819]: self.doIteration(t) 
beah-beaker-backend[4819]: File "/usr/lib64/python2.7/site-packages/twisted/internet/epollreactor.py", line 362, in doPoll 
beah-beaker-backend[4819]: l = self._poller.poll(timeout, len(self._selectables)) 
beah-beaker-backend[4819]: exceptions.OverflowError: timeout is too large 
beah-beaker-backend[4819]: Unhandled Error 
beah-beaker-backend[4819]: Traceback (most recent call last): 
beah-beaker-backend[4819]: File "/usr/bin/beah-beaker-backend", line 9, in <module> 
beah-beaker-backend[4819]: load_entry_point('beah==0.7.9.dev201509141901', 'console_scripts', 'beah-beaker-backend')() 
beah-beaker-backend[4819]: File "/usr/lib/python2.7/site-packages/beah/backends/beakerlc.py", line 2074, in main 
beah-beaker-backend[4819]: debug.runcall(reactor.run) 
beah-beaker-backend[4819]: File "/usr/lib/python2.7/site-packages/beah/core/debug.py", line 11, in runcall 
beah-beaker-backend[4819]: a_callable(*args, **kwargs) 
beah-beaker-backend[4819]: File "/usr/lib64/python2.7/site-packages/twisted/internet/base.py", line 1169, in run 
beah-beaker-backend[4819]: self.mainLoop() 


The console logs were filling up with the following messages causing the conserver logging file system to fill up:

beah-beaker-backend[5358]: File "/usr/lib64/python2.7/site-packages/twisted/internet/base.py", line 1181, in mainLoop
beah-beaker-backend[5358]: self.doIteration(t)
beah-beaker-backend[5358]: File "/usr/lib64/python2.7/site-packages/twisted/internet/epollreactor.py", line 362, in doPoll
beah-beaker-backend[5358]: l = self._poller.poll(timeout, len(self._selectables))
beah-beaker-backend[5358]: exceptions.OverflowError: timeout is too large
beah-beaker-backend[5358]: 2015-06-30 23:59:20,289 backend.twisted emit: ERROR Unhandled Error
beah-beaker-backend[5358]: Traceback (most recent call last):
beah-beaker-backend[5358]: File "/usr/bin/beah-beaker-backend", line 9, in <module>
beah-beaker-backend[5358]: load_entry_point('beah==0.7.9.dev201509141901', 'console_scripts', 'beah-beaker-backend')()
beah-beaker-backend[5358]: File "/usr/lib/python2.7/site-packages/beah/backends/beakerlc.py", line 2074, in main
beah-beaker-backend[5358]: debug.runcall(reactor.run)
beah-beaker-backend[5358]: File "/usr/lib/python2.7/site-packages/beah/core/debug.py", line 11, in runcall
beah-beaker-backend[5358]: a_callable(*args, **kwargs)
beah-beaker-backend[5358]: File "/usr/lib64/python2.7/site-packages/twisted/internet/base.py", line 1169, in run
beah-beaker-backend[5358]: self.mainLoop()
beah-beaker-backend[5358]: --- <exception caught here> ---
beah-beaker-backend[5358]: File "/usr/lib64/python2.7/site-packages/twisted/internet/base.py", line 1181, in mainLoop
beah-beaker-backend[5358]: self.doIteration(t)
beah-beaker-backend[5358]: File "/usr/lib64/python2.7/site-packages/twisted/internet/epollreactor.py", line 362, in doPoll
beah-beaker-backend[5358]: l = self._poller.poll(timeout, len(self._selectables))
beah-beaker-backend[5358]: exceptions.OverflowError: timeout is too large
beah-beaker-backend[5358]: Unhandled Error
beah-beaker-backend[5358]: Traceback (most recent call last):
beah-beaker-backend[5358]: File "/usr/bin/beah-beaker-backend", line 9, in <module>
beah-beaker-backend[5358]: load_entry_point('beah==0.7.9.dev201509141901', 'console_scripts', 'beah-beaker-backend')()
beah-beaker-backend[5358]: File "/usr/lib/python2.7/site-packages/beah/backends/beakerlc.py", line 2074, in main
beah-beaker-backend[5358]: debug.runcall(reactor.run)
beah-beaker-backend[5358]: File "/usr/lib/python2.7/site-packages/beah/core/debug.py", line 11, in runcall
beah-beaker-backend[5358]: a_callable(*args, **kwargs)
beah-beaker-backend[5358]: File "/usr/lib64/python2.7/site-packages/twisted/internet/base.py", line 1169, in run
beah-beaker-backend[5358]: self.mainLoop()
beah-beaker-backend[5358]: --- <exception caught here> ---
beah-beaker-backend[5358]: File "/usr/lib64/python2.7/site-packages/twisted/internet/base.py", line 1181, in mainLoop
beah-beaker-backend[5358]: self.doIteration(t)
beah-srv[5357]: File "/usr/lib/python2.7/site-packages/beah/core/debug.py", line 11, in runcall
beah-srv[5357]: a_callable(*args, **kwargs)
beah-srv[5357]: File "/usr/lib64/python2.7/site-packages/twisted/internet/base.py", line 1169, in run
beah-srv[5357]: self.mainLoop()
beah-srv[5357]: --- <exception caught here> ---
beah-srv[5357]: File "/usr/lib64/python2.7/site-packages/twisted/internet/base.py", line 1181, in mainLoop
beah-srv[5357]: self.doIteration(t)
beah-srv[5357]: File "/usr/lib64/python2.7/site-packages/twisted/internet/epollreactor.py", line 362, in doPoll
beah-srv[5357]: l = self._poller.poll(timeout, len(self._selectables))
beah-srv[5357]: exceptions.OverflowError: timeout is too large
beah-srv[5357]: Unhandled Error
beah-srv[5357]: Traceback (most recent call last):
beah-srv[5357]: File "/usr/bin/beah-srv", line 9, in <module>
beah-srv[5357]: load_entry_point('beah==0.7.9.dev201509141901', 'console_scripts', 'beah-srv')()
beah-srv[5357]: File "/usr/lib/python2.7/site-packages/beah/bin/srv.py", line 39, in main
beah-srv[5357]: debug.runcall(reactor.run)
beah-srv[5357]: File "/usr/lib/python2.7/site-packages/beah/core/debug.py", line 11, in runcall
beah-srv[5357]: a_callable(*args, **kwargs)
beah-srv[5357]: File "/usr/lib64/python2.7/site-packages/twisted/internet/base.py", line 1169, in run
beah-srv[5357]: self.mainLoop()
beah-srv[5357]: --- <exception caught here> ---
beah-srv[5357]: File "/usr/lib64/python2.7/site-packages/twisted/internet/base.py", line 1181, in mainLoop
beah-srv[5357]: self.doIteration(t)
beah-srv[5357]: File "/usr/lib64/python2.7/site-packages/twisted/internet/epollreactor.py", line 362, in doPoll
beah-srv[5357]: l = self._poller.poll(timeout, len(self._selectables))
beah-srv[5357]: exceptions.OverflowError: timeout is too large
beah-srv[5357]: 2015-06-30 23:59:19,075 beah.twisted emit: ERROR Unhandled Error
beah-srv[5357]: Traceback (most recent call last):
beah-srv[5357]: File "/usr/bin/beah-srv", line 9, in <module>
beah-srv[5357]: load_entry_point('beah==0.7.9.dev201509141901', 'console_scripts', 'beah-srv')()
beah-srv[5357]: File "/usr/lib/python2.7/site-packages/beah/bin/srv.py", line 39, in main
beah-srv[5357]: debug.runcall(reactor.run)
beah-srv[5357]: File "/usr/lib/python2.7/site-packages/beah/core/debug.py", line 11, in runcall
beah-srv[5357]: a_callable(*args, **kwargs)
beah-srv[5357]: File "/usr/lib64/python2.7/site-packages/twisted/internet/base.py", line 1169, in run
beah-srv[5357]: self.mainLoop()
beah-srv[5357]: --- <exception caught here> ---


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 3 Dan Callaghan 2015-10-18 18:59:48 EDT
This is unfortunately a long-standing issue with how beah/Twisted fail to deal with changing system time. Dupe of bug 1201624, bug 1063647, bug 849587, bug 639255.

*** This bug has been marked as a duplicate of bug 1063647 ***

Note You need to log in before you can comment on or make changes to this bug.