Bug 1272620 - multipathd remove map foo responds with "ok"
multipathd remove map foo responds with "ok"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
7.3
Unspecified Linux
unspecified Severity low
: rc
: ---
Assigned To: Ben Marzinski
Lin Li
Steven J. Levine
:
Depends On: 1271381
Blocks: 1313485 1295577
  Show dependency treegraph
 
Reported: 2015-10-16 19:40 EDT by Ben Marzinski
Modified: 2017-05-10 22:30 EDT (History)
11 users (show)

See Also:
Fixed In Version: device-mapper-multipath-0.4.9-87.el7
Doc Type: Bug Fix
Doc Text:
The *multipathd* daemon now responds to failed removes with `fail` rather than `ok` Previously, the *multipathd* daemon did not retain the error status when removing a path or a map failed and would respond to failed removes with `ok`. With this fix, *multipathd* now responds to failed removes with `fail`.
Story Points: ---
Clone Of: 1271381
Environment:
Last Closed: 2016-11-04 04:13:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Marzinski 2015-10-16 19:40:15 EDT
+++ This bug was initially created as a clone of Bug #1271381 +++

Description of problem:

multipathd responds with "ok" to any input <device> parameter for the remove command.


How reproducible:
100%

Steps to Reproduce:
1. Issue command with invalid device name:

# multipathd remove map foo
ok

Expected results:

Error message to indicate that an invalid device name was specified.

Additional info:
Comment 2 Lin Li 2016-04-25 05:27:20 EDT
Reproduced on device-mapper-multipath-0.4.9-77.el7
1). #yum install device-mapper device-mapper-multipath
2). # rpm -qa | grep multipath
device-mapper-multipath-libs-0.4.9-77.el7.x86_64
device-mapper-multipath-0.4.9-77.el7.x86_64
3). # mpathconf --enable
4). # service multipathd restart
Redirecting to /bin/systemctl restart  multipathd.service
5). # multipathd remove map foo   <-------invalid device name
ok
6). # multipathd remove map absdssf <--------invalid device name
ok


Verified on device-mapper-multipath-0.4.9-87.el7
1). #yum install device-mapper device-mapper-multipath
2). # rpm -qa | grep multipath
device-mapper-multipath-0.4.9-87.el7.x86_64
device-mapper-multipath-sysvinit-0.4.9-87.el7.x86_64
device-mapper-multipath-libs-0.4.9-87.el7.x86_64
3). mpathconf --enable
4). # service multipathd restart
Redirecting to /bin/systemctl restart  multipathd.service
5).# multipathd remove map foo   <-------invalid device name
fail
6). # multipathd remove map absdssf <--------invalid device name
fail
Comment 5 errata-xmlrpc 2016-11-04 04:13:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2536.html

Note You need to log in before you can comment on or make changes to this bug.