Bug 1272646 - gnome-keyring prevents the graphical login into a mate session
gnome-keyring prevents the graphical login into a mate session
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-keyring (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F23FinalBlocker F23FinalFreezeException
  Show dependency treegraph
 
Reported: 2015-10-17 04:32 EDT by Giulio 'juliuxpigface'
Modified: 2015-10-19 17:25 EDT (History)
8 users (show)

See Also:
Fixed In Version: gnome-keyring-3.18.1-2.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-19 17:07:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of '# journalctl -u lightdm | tail' (655 bytes, text/plain)
2015-10-17 04:32 EDT, Giulio 'juliuxpigface'
no flags Details

  None (edit)
Description Giulio 'juliuxpigface' 2015-10-17 04:32:41 EDT
Created attachment 1083886 [details]
Output of '# journalctl -u lightdm | tail'

Description of problem:
In Mate Final TC11, login through lightdm was stuck. After consulting journalctl, it was clear enough that gnome-keyring was the source of the issue.

Killing gnome-keyring resulted in a successful login.

Version-Release number of selected component (if applicable):
gnome-keyring-3.18.0-4.fc23.i686

How reproducible:
This was the first boot, I haven't honestly tried to reproduce it yet, but I'll do it as soon as possible.

It will also be interesting a test with other environments which use lightdm as login manager (e.g.: xfce and cinnamon)

Steps to Reproduce:
1. Install Fedora Final TC11 compose (from Mate live spin)
2. Boot the installed system
3. Log in through lightdm

Actual results:
The graphical session is stuck until the kill of gnome-keyring.

Expected results:
The graphical session should work normally

Additional info:
1) Mate Final TC11 i686
2) qemu-kvm guest
3) xfs filesystem on "/" partition
4) no autologin enabled
Comment 1 Giulio 'juliuxpigface' 2015-10-17 05:35:29 EDT
(In reply to Giulio 'juliuxpigface' from comment #0)
> 
> How reproducible:
> This was the first boot, I haven't honestly tried to reproduce it yet, but
> I'll do it as soon as possible.
> 
> It will also be interesting a test with other environments which use lightdm
> as login manager (e.g.: xfce and cinnamon)
> 

I've reproduced it with the Xfce spin.

The strange thing is, the issue happens only on the very first boot.
With the successive attempts, the login works as expected (this is true with Mate too).

I'll try Gnome too and report here how it behaves.
Comment 2 Adam Williamson 2015-10-17 05:48:00 EDT
This is worth at least a proposal for Final blocker, if it affects Xfce - Xfce is a blocking desktop for ARM in F23. Alpha: "A system installed with a release-blocking desktop must boot to a log in screen where it is possible to log in to a working desktop using a user account created during installation or a 'first boot' utility."
Comment 3 Stef Walter 2015-10-17 08:49:40 EDT
FYI gnome-keyring 3.18.1 has been released upstream. This is very likely fixed with 3.18.1.
Comment 4 Kalev Lember 2015-10-17 10:41:49 EDT
I'm kicking off a 3.18.1 build, let's see how it works in testing.

If it seems to be no worse than 3.18.0-4, it probably makes sense to pull in this version instead for the next compose as the downstream fixes we had in -4 had quite a bit of upstream scrutiny and more improvements before they were committed. Also, I doubt we'll have a definitive answer if this fixes the MATE issues until we get an installer image with it.
Comment 5 Fedora Update System 2015-10-17 10:50:07 EDT
gnome-keyring-3.18.1-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-b63ce6ef7b
Comment 6 Fedora Update System 2015-10-17 14:20:50 EDT
gnome-keyring-3.18.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update gnome-keyring'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-b63ce6ef7b
Comment 7 Fedora Update System 2015-10-17 15:02:35 EDT
gnome-keyring-3.18.1-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-b63ce6ef7b
Comment 8 Adam Williamson 2015-10-17 16:32:53 EDT
I reproduced the bug with the TC11 64-bit Xfce live - after install and user creation, trying to login just showed the background, no Xfce ever appeared. Then I built a live with gnome-keyring-3.18.1-2.fc23, and it does indeed appear to fix the bug.
Comment 9 satellitgo 2015-10-17 19:22:24 EDT
also with

Fedora-Live-MATE_Compiz-x86_64-23-TC11.iso

https://fedoraproject.org/wiki/Test_Results:Fedora_23_Final_TC11_Installation#Default_boot_and_install
Comment 10 satellitgo 2015-10-17 19:25:57 EDT
flashes to black and then to wallpaper after login
Comment 11 Fedora Update System 2015-10-18 15:53:34 EDT
gnome-keyring-3.18.1-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update gnome-keyring'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-b63ce6ef7b
Comment 12 Adam Williamson 2015-10-19 15:39:55 EDT
Discussed at 2015-10-19 blocker review meeting: https://meetbot.fedoraproject.org/fedora-blocker-review/2015-10-19/f23-blocker-review.2015-10-19-16.00.html . Accepted as a blocker per criterion cited in #c2 (we confirmed it affects Xfce on ARM).
Comment 13 satellitgo 2015-10-19 17:06:20 EDT
soas li-t-d USB stops at wallpaper also TC-11 x86_64 after install to bare metal
Comment 14 Fedora Update System 2015-10-19 17:07:37 EDT
gnome-keyring-3.18.1-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 15 Kalev Lember 2015-10-19 17:25:30 EDT
*** Bug 1273184 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.