This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1272649 - AttributeError: 'NoneType' object has no attribute 'rstrip'
AttributeError: 'NoneType' object has no attribute 'rstrip'
Status: CLOSED DUPLICATE of bug 1272936
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Mráka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-17 05:13 EDT by Ali Akcaagac
Modified: 2015-10-19 09:17 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-19 09:17:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ali Akcaagac 2015-10-17 05:13:19 EDT
-bash-4.3$ sudo dnf builddep picard
enabling rpmfusion-nonfree-updates-testing-source repository
enabling updates-testing-source repository
enabling fedora-source repository
enabling rpmfusion-free-updates-testing-source repository
enabling rpmfusion-free-updates-source repository
enabling rpmfusion-free-source repository
enabling rpmfusion-nonfree-updates-source repository
enabling rpmfusion-nonfree-source repository
enabling updates-source repository
RPM Fusion for Fedora 22 - Nonfree - Test Updates Source                                                              6.1 kB/s | 397  B     00:00    
Fedora 22 - Test Updates Source                                                                                       1.2 MB/s | 397 kB     00:00    
RPM Fusion for Fedora 22 - Nonfree - Updates Source                                                                    42 kB/s | 7.6 kB     00:00    
RPM Fusion for Fedora 22 - Free - Source                                                                              429 kB/s |  83 kB     00:00    
Fedora 22 - Updates Source                                                                                            981 kB/s | 1.9 MB     00:01    
RPM Fusion for Fedora 22 - Nonfree - Source                                                                           207 kB/s |  35 kB     00:00    
RPM Fusion for Fedora 22 - Free - Updates Source                                                                       62 kB/s |  13 kB     00:00    
RPM Fusion for Fedora 22 - Free - Test Updates Source                                                                 2.2 kB/s | 397  B     00:00    
Fedora 22 - Source                                                                                                    1.4 MB/s | 5.8 MB     00:04    
Last metadata expiration check performed 0:00:04 ago on Sat Oct 17 11:10:17 2015.
Traceback (most recent call last):
  File "/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 198, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 136, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1091, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf-plugins/builddep.py", line 76, in inner
    return func(*args, **kwds)
  File "/usr/lib/python2.7/site-packages/dnf-plugins/builddep.py", line 142, in run
    self._remote_deps(pkgspec)
  File "/usr/lib/python2.7/site-packages/dnf-plugins/builddep.py", line 213, in _remote_deps
    package).get_best_query(self.base.sack)})
  File "/usr/lib/python2.7/site-packages/dnf-plugins/builddep.py", line 212, in <setcomp>
    for pkg in dnf.subject.Subject(
  File "/usr/lib/python2.7/site-packages/dnfpluginscore/lib.py", line 170, in package_source_name
    srcname = package.sourcerpm.rstrip(".src.rpm")
AttributeError: 'NoneType' object has no attribute 'rstrip'
-bash-4.3$ dnf --version
1.1.3
  Installed: dnf-0:1.1.3-1.fc22.noarch at 2015-10-15 10:15
  Built    : Fedora Project at 2015-10-14 16:53

  Installed: rpm-0:4.12.0.1-12.fc22.i686 at 2015-06-30 15:25
  Built    : Fedora Project at 2015-06-29 10:34
-bash-4.3$ 

The latest update available through dnf update. Looks like a minor coding issue?
Comment 1 Michael Mráka 2015-10-19 09:11:44 EDT
> The latest update available through dnf update. Looks like a minor coding
> issue?

Yes, sorry for it. Fixed in
https://github.com/rpm-software-management/dnf-plugins-core/commit/0950bd8e47b21a48b746fdc5fa85839e202e6053
Comment 2 Michael Mráka 2015-10-19 09:17:29 EDT

*** This bug has been marked as a duplicate of bug 1272936 ***

Note You need to log in before you can comment on or make changes to this bug.