This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1272936 - [abrt] dnf: lib.py:170:package_source_name:AttributeError: 'NoneType' object has no attribute 'rstrip'
[abrt] dnf: lib.py:170:package_source_name:AttributeError: 'NoneType' object ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Mráka
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:e400ef6901bebb0843e4e5fb6e0...
: Reopened
: 1272649 1276037 1277000 1277526 1279307 1279410 1281472 1281554 1283319 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-19 05:08 EDT by Michal Schmidt
Modified: 2015-11-30 18:24 EST (History)
25 users (show)

See Also:
Fixed In Version: dnf-plugins-core-0.1.14-1.fc23 dnf-plugins-core-0.1.14-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-30 18:24:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: _var_log_dnf.log (241.35 KB, text/plain)
2015-10-19 05:08 EDT, Michal Schmidt
no flags Details
File: backtrace (1.44 KB, text/plain)
2015-10-19 05:08 EDT, Michal Schmidt
no flags Details
File: dnf-makecache.log (107.07 KB, text/plain)
2015-10-19 05:08 EDT, Michal Schmidt
no flags Details
File: environ (2.61 KB, text/plain)
2015-10-19 05:08 EDT, Michal Schmidt
no flags Details

  None (edit)
Description Michal Schmidt 2015-10-19 05:08:39 EDT
Description of problem:
I run "dnf builddep systemd".
It is reproducible.

Version-Release number of selected component:
dnf-1.1.3-1.fc23

Additional info:
reporter:       libreport-2.6.3
cmdline:        /usr/bin/python3 -OO /usr/bin/dnf builddep systemd
executable:     /usr/bin/dnf
kernel:         4.2.3-300.fc23.x86_64
runlevel:       N 3
type:           Python3
uid:            0

Truncated backtrace:
lib.py:170:package_source_name:AttributeError: 'NoneType' object has no attribute 'rstrip'

Traceback (most recent call last):
  File "/usr/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 198, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 136, in _main
    cli.run()
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 1091, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python3.4/site-packages/dnf-plugins/builddep.py", line 76, in inner
    return func(*args, **kwds)
  File "/usr/lib/python3.4/site-packages/dnf-plugins/builddep.py", line 142, in run
    self._remote_deps(pkgspec)
  File "/usr/lib/python3.4/site-packages/dnf-plugins/builddep.py", line 213, in _remote_deps
    package).get_best_query(self.base.sack)})
  File "/usr/lib/python3.4/site-packages/dnf-plugins/builddep.py", line 212, in <setcomp>
    for pkg in dnf.subject.Subject(
  File "/usr/lib/python3.4/site-packages/dnfpluginscore/lib.py", line 170, in package_source_name
    srcname = package.sourcerpm.rstrip(".src.rpm")
AttributeError: 'NoneType' object has no attribute 'rstrip'

Local variables in innermost frame:
package: <hawkey.Package object id 56732, systemd-222-7.fc23.src, updates-testing-source>
Comment 1 Michal Schmidt 2015-10-19 05:08:43 EDT
Created attachment 1084307 [details]
File: _var_log_dnf.log
Comment 2 Michal Schmidt 2015-10-19 05:08:45 EDT
Created attachment 1084308 [details]
File: backtrace
Comment 3 Michal Schmidt 2015-10-19 05:08:46 EDT
Created attachment 1084309 [details]
File: dnf-makecache.log
Comment 4 Michal Schmidt 2015-10-19 05:08:47 EDT
Created attachment 1084310 [details]
File: environ
Comment 6 Michael Mráka 2015-10-19 09:17:29 EDT
*** Bug 1272649 has been marked as a duplicate of this bug. ***
Comment 7 Honza Silhan 2015-10-30 13:19:29 EDT
*** Bug 1276037 has been marked as a duplicate of this bug. ***
Comment 8 Kevin Lipe 2015-11-01 23:55:42 EST
*** Bug 1277000 has been marked as a duplicate of this bug. ***
Comment 9 Stefan Ring 2015-11-03 14:31:03 EST
The patch from comment 5 works for me.
Comment 10 Michael Mráka 2015-11-04 06:42:20 EST
*** Bug 1277526 has been marked as a duplicate of this bug. ***
Comment 11 Michael Mráka 2015-11-11 06:31:11 EST
*** Bug 1279307 has been marked as a duplicate of this bug. ***
Comment 12 Michael Mráka 2015-11-11 07:27:11 EST
*** Bug 1279410 has been marked as a duplicate of this bug. ***
Comment 13 Robbie Harwood 2015-11-11 19:11:08 EST
When is this actually going to be fixed in Fedora?  The number of duplicates alone suggests that this is affecting many people.
Comment 14 Lyude 2015-11-12 17:57:05 EST
Whoops, sorry about that! Accidental
Comment 15 Jean-François Fortin Tam 2015-11-13 11:49:24 EST
*** Bug 1281472 has been marked as a duplicate of this bug. ***
Comment 16 Lyude 2015-11-13 14:42:00 EST
Is there any reason why this hasn't, at the very least, been included in a release of dnf? This bug is breaking `dnf builddep` completely on Fedora 22 and Fedora 23, I can even reproduce it on my system after updating. I still don't see any new releases on the github page for dnf nor anything in bodhi awaiting testing.
Comment 17 Fedora Update System 2015-11-16 14:07:30 EST
dnf-plugins-core-0.1.14-1.fc23 dnf-1.1.4-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-fe6e8b885b
Comment 18 Ali Akcaagac 2015-11-17 05:45:29 EST
I like to remind, that my bug report (which got closed as duplicate: Comment #6) refers to Fedora 22. So releasing only Fedora 23 packages won't make the problem go away. At least for a subset of users that still rely on Fedora 22.
Comment 19 Honza Silhan 2015-11-18 08:56:30 EST
*** Bug 1281554 has been marked as a duplicate of this bug. ***
Comment 20 Fedora Update System 2015-11-18 11:26:33 EST
dnf-1.1.4-1.fc22 dnf-plugins-core-0.1.14-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-6137119aff
Comment 21 Fedora Update System 2015-11-18 11:52:23 EST
dnf-1.1.4-1.fc23, dnf-plugins-core-0.1.14-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update dnf dnf-plugins-core'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-fe6e8b885b
Comment 22 Francesco Frassinelli (frafra) 2015-11-18 15:28:46 EST
Another user experienced a similar problem:

I was trying to install some *-devel dependencies using dnf builddep.

reporter:       libreport-2.6.3
cmdline:        /usr/bin/python3 -OO /bin/dnf builddep gnome-abrt
event_log:      2015-11-18-21:28:03> ('report_uReport' completato con successo)
executable:     /bin/dnf
kernel:         4.2.5-300.fc23.x86_64
package:        dnf-1.1.3-1.fc23
reason:         lib.py:170:package_source_name:AttributeError: 'NoneType' object has no attribute 'rstrip'
runlevel:       N 5
type:           Python3
uid:            0
Comment 23 Fedora Update System 2015-11-19 04:52:25 EST
dnf-1.1.4-1.fc23, dnf-plugins-core-0.1.14-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 24 Michael Mráka 2015-11-19 06:19:19 EST
*** Bug 1283319 has been marked as a duplicate of this bug. ***
Comment 25 Fedora Update System 2015-11-19 09:51:26 EST
dnf-1.1.4-1.fc22, dnf-plugins-core-0.1.14-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update dnf-plugins-core dnf'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-6137119aff
Comment 26 Fedora Update System 2015-11-30 18:23:19 EST
dnf-1.1.4-1.fc22, dnf-plugins-core-0.1.14-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.