Bug 127265 - keymaps use "currency" instead of "euro"
keymaps use "currency" instead of "euro"
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kbd (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
Brock Organ
:
: 75316 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-05 09:22 EDT by Jarkko
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-18 17:30:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jarkko 2004-07-05 09:22:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
Font latarcyrheb-sun16 is missing euro character. If I set up UTF-8 
(the default) in /etc/sysconfig/i18n, I can't use euro at console 
because it is missing in latarcyrheb-sun16.

(Sorry, if I chose the wrong conponent for this one.)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Set up UTF-8 and latarcyrheb-sun16 as sysfont (this is the default)
2. go to console
3. try to write € (euro)
    

Actual Results:  I got the global currency symbol, not euro.

Expected Results:  € (euro)

Additional info:
Comment 1 Jakub Jelinek 2004-07-06 17:51:27 EDT
It has EURO SIGN character, but not EURO-CURRENCY SIGN:
zcat /lib/kbd/consolefonts/latarcyrheb-sun16.psfu.gz | psfgettable - | grep 20a
0x0ad   U+20ac
zcat /usr/share/i18n/charmaps/UTF-8.gz | grep EURO
<U20A0>     /xe2/x82/xa0 EURO-CURRENCY SIGN
<U20AC>     /xe2/x82/xac EURO SIGN
No idea why Unicode has two of these.
Try:
zcat /lib/kbd/consolefonts/latarcyrheb-sun16.psfu.gz > /tmp/latarcyrheb-sun16.psfu; psfgettable /tmp/latarcyrheb-sun16.psfu | sed 's/U+20ac$/& U+20a0/' > /tmp/latarcyrheb-sun16.utbl; psfstriptable /tmp/latarcyrheb-sun16.psfu /tmp/latarcyrheb-sun16.psf; psfaddtable /tmp/latarcyrheb-sun16.psf /tmp/latarcyrheb-sun16.utbl /tmp/latarcyrheb-sun16.psfu; gzip -9 /tmp/latarcyrheb-sun16.psfu
and as root mv -f /lib/kbd/consolefonts/latarcyrheb-sun16{,-old}.psfu.gz
cp {/tmp,/lib/kbd/consolefonts}latarcyrheb-sun16.psfu.gz
Comment 2 Eido Inoue 2004-07-06 17:56:21 EDT
comment 1: the "Euro-currency sign" is not the real euro sign. it is a
historical character and should never be used

The euro is actually in the font... this can be seen by dumping the
font. The problem is that the Euro is mapped to the wrong Unicode code
point.
Comment 3 Eido Inoue 2004-08-10 19:14:25 EDT
*** Bug 75316 has been marked as a duplicate of this bug. ***
Comment 4 Miloslav Trmač 2005-02-18 17:30:50 EST
I have sent a patch replacing "currency" by "euro" in most maps upstream;
we will get the change if/when it is accepted there.

Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.