Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1272829 - [Usability] Product, Component and Subcomponent selectors should be usable via keyboard only
Summary: [Usability] Product, Component and Subcomponent selectors should be usable vi...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: 4.4
Assignee: PnT DevOps Devs
QA Contact: tools-bugs
URL:
Whiteboard:
: 1272843 (view as bug list)
Depends On: 1265079
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-19 03:05 UTC by Jason McDonald
Modified: 2018-12-09 06:29 UTC (History)
6 users (show)

Fixed In Version: 4.4.10045.3
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1272843 (view as bug list)
Environment:
Last Closed: 2015-12-16 02:14:00 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1276222 0 unspecified CLOSED Component select list only show after press "Ctrl+Shift+A" twice in Firefox in the case gnome enabled more than 2 input ... 2021-02-22 00:41:40 UTC

Internal Links: 1276222

Description Jason McDonald 2015-10-19 03:05:05 UTC
Description of problem:
It is not currently possible to fully navigate the new Product, Component and Subcomponent selectors with the keyboard.  This slows down the workflow significantly for users who prefer to use the keyboard.

In both expanded and collapsed states, the selector should respond to (at least) the up and down arrows, pg-up, pg-down, home and end keys, making ajax calls behind the scenes to fill in enough of the missing data to give a decent user experience, but not incurring the time cost of loading the whole list in one call unless the user asks for that.

There should also be a keyboard-driven equivalent of the "Click to list all components" function, which currently appears to respond only to a mouse click.

Version-Release number of selected component (if applicable):
4.4.9039

How reproducible:
Always

Steps to Reproduce:
1. Open a bug in Red hat Enterprise Linux 6
2. Try to move the bug to Fedora's virt-manager component using only the directional keys on the keyboard instead of typing the component name (pretend you don't know the component name and want to scan through the list of available components to find a suitable component).

Actual results:
There is no way to navigate through the component list using the directional keys.

Expected results:
The part of the list that is already loaded can be navigated using the directional keys, additional items are loaded as needed, and the full list can be loaded using the keyboard.

Additional info:
none

Comment 1 Jason McDonald 2015-10-19 03:24:32 UTC
This bug should be fixed for 4.4. It is a direct consequence of the recent BZ upgrade and is causing our users significant frustration.

Comment 2 Jason McDonald 2015-10-19 05:00:20 UTC
(In reply to Jason McDonald from comment #0)
> There should also be a keyboard-driven equivalent of the "Click to list all
> components" function, which currently appears to respond only to a mouse
> click.

This part has been spun off into Bug 1272843.

Comment 6 Hao Chang Yu 2015-10-27 04:51:45 UTC
*** Bug 1272843 has been marked as a duplicate of this bug. ***

Comment 7 Rony Gong 🔥 2015-10-29 03:14:15 UTC
Tested on 
QA environment(bzperfweb01.app.qa) with version(4.4.10043-2, DB: psql)
Result: FAil
Steps:
1.In Firefox, it couldn't list all components by keys: Ctrl+Shift+A  when cursor located in component field.

But it works well in Chrome

Comment 8 Rony Gong 🔥 2015-10-29 05:40:46 UTC
(In reply to Rony Gong from comment #7)
> Tested on 
> QA environment(bzperfweb01.app.qa) with version(4.4.10043-2, DB: psql)
> Result: FAil
> Steps:
> 1.In Firefox, it couldn't list all components by keys: Ctrl+Shift+A  when
> cursor located in component field.
> 
> But it works well in Chrome

After restart the test machine, for Firefox, it must Ctrl+Shift+A twice, then it could pop up component list.

Comment 9 Rony Gong 🔥 2015-10-29 06:54:51 UTC
(In reply to Rony Gong from comment #8)
> (In reply to Rony Gong from comment #7)
> > Tested on 
> > QA environment(bzperfweb01.app.qa) with version(4.4.10043-2, DB: psql)
> > Result: FAil
> > Steps:
> > 1.In Firefox, it couldn't list all components by keys: Ctrl+Shift+A  when
> > cursor located in component field.
> > 
> > But it works well in Chrome
> 
> After restart the test machine, for Firefox, it must Ctrl+Shift+A twice,
> then it could pop up component list.

I've file a new bug 1276222 to track this.

Comment 10 Matt Tyson 🤬 2015-12-16 02:14:00 UTC
This change is now live. If there are any issues, do not reopen this bug. Instead, you should create a new bug and reference this bug.


Note You need to log in before you can comment on or make changes to this bug.