This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1272843 - [Usability] Make it possible to load all components via the keyboard
[Usability] Make it possible to load all components via the keyboard
Status: CLOSED DUPLICATE of bug 1272829
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
4.4
Unspecified Unspecified
unspecified Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-19 00:58 EDT by Jason McDonald
Modified: 2015-10-27 00:51 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1272829
Environment:
Last Closed: 2015-10-27 00:51:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason McDonald 2015-10-19 00:58:54 EDT
+++ This bug was initially created as a clone of Bug #1272829 +++

Description of problem:
When entering a bug, editing a bug and searching bugs, it is not currently possible to activate the "Click to list all components" widget via the keyboard.

Version-Release number of selected component (if applicable):
4.4.9039

How reproducible:
Always

Steps to Reproduce:
1. Go to New->Red Hat->Red Hat Enterprise Linux 7.
2. Try to load the full component list without using the mouse.

Actual results:
There is no way to load the component list using only the keyboard -- there appears to be no keyboard shortcut for the widget and it can't be focused using the Tab key.

Expected results:
The full component list can be loaded via a keyboard shortcut and/or a button that is included in the tab order.

Additional info:
none
Comment 1 Jeff Fearn 2015-10-21 02:26:11 EDT
This just needs an anchor code around the span and the onclick code moved from the din to the anchor. That will make it so the anchor can be focused and activated from the keyboard. href="#" to make the anchor behave.
Comment 2 Hao Chang Yu 2015-10-27 00:51:45 EDT

*** This bug has been marked as a duplicate of bug 1272829 ***

Note You need to log in before you can comment on or make changes to this bug.