Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1272978 - Fields "Console User" and "Console Client IP" stuck in N/A state (while field "Logged-in User" provides actual information.)
Summary: Fields "Console User" and "Console Client IP" stuck in N/A state (while field...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-3.6.1
: 3.6.1
Assignee: Vinzenz Feenstra [evilissimo]
QA Contact: Petr Matyáš
URL:
Whiteboard:
Depends On:
Blocks: 1272502
TreeView+ depends on / blocked
 
Reported: 2015-10-19 10:42 UTC by Andrei Stepanov
Modified: 2017-02-27 12:13 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-20 01:28:43 UTC
oVirt Team: Virt
Target Upstream Version:


Attachments (Terms of Use)
vdsm log (7.87 MB, text/plain)
2015-10-19 10:49 UTC, Andrei Stepanov
no flags Details
Engine log (2.39 MB, text/plain)
2015-10-19 10:50 UTC, Andrei Stepanov
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 49103 0 master MERGED Frontend: ConsoleUserName & ClientIP update regression fix Never
oVirt gerrit 49132 0 ovirt-engine-3.6 MERGED Frontend: ConsoleUserName & ClientIP update regression fix Never
oVirt gerrit 50016 0 ovirt-engine-3.6.1 MERGED Frontend: ConsoleUserName & ClientIP update regression fix Never

Description Andrei Stepanov 2015-10-19 10:42:16 UTC
"Guest info" tab for VM has fields:
Console User / Console Client IP
The state of above fields is always : [N/A]

RHEVM 3.6.0-0.18.el6

Connection to VM with remote-viewer using SPICE protocol doesn't affect on above fields.

Guest system has:
rhevm-guest-agent-  1.0.11-2.el7ev


I should mention that, field "Logged-in User" provides actual information.

Comment 1 Andrei Stepanov 2015-10-19 10:49:32 UTC
Created attachment 1084333 [details]
vdsm log

Comment 2 Andrei Stepanov 2015-10-19 10:50:31 UTC
Created attachment 1084334 [details]
Engine log

Comment 3 Omer Frenkel 2015-10-20 15:08:42 UTC
might be related to bug 1272502

Comment 5 Petr Matyáš 2015-12-03 10:26:31 UTC
These fields are still blank

rhevm-guest-agent-common-1.0.11-2.el6ev
rhevm-3.6.1.1-0.1.el6.noarch

Comment 6 Michal Skrivanek 2015-12-04 13:50:39 UTC
yeah, because it's in 3.6.1-2, you tested a week old build and as you can see the bug was only moved to ON_QA yesterday. 
Not sure why there was no proper "Fixed in Version", David maybe knows?

Comment 7 Petr Matyáš 2015-12-04 15:01:12 UTC
Yes, that's exactly the build I tested. Version of RHEVM PACKAGE is 3.6.1-1 in that build.

Comment 8 David Caro 2015-12-04 16:46:53 UTC
Eyal knows best

Comment 9 Eyal Edri 2015-12-06 12:14:00 UTC
pm decision was to stop using fixed in version field and work only with target milestone.

i.e the bug should be tested with latest build for the current milestone.

adding pm to confirm.

Comment 10 Yaniv Lavi 2015-12-06 12:18:44 UTC
(In reply to Eyal Edri from comment #9)
> pm decision was to stop using fixed in version field and work only with
> target milestone.
> 
> i.e the bug should be tested with latest build for the current milestone.
> 
> adding pm to confirm.

Yes, RHEV bugs can't have accurate target releases, please use the latest 3.6.1 repo to test.

Comment 11 Petr Matyáš 2015-12-06 12:58:48 UTC
I did use the latest release

Comment 12 Michal Skrivanek 2015-12-07 09:24:11 UTC
ah, right, not 3.6.1

Comment 13 Eyal Edri 2015-12-07 09:38:38 UTC
michal if we want this for 3.6.1 it needs to be backported to 3.6.1 branch.
also - we need to see if we are doing another build for beta2 this week.

Comment 14 Eyal Edri 2015-12-09 09:05:18 UTC
part of the 3rd ovirt-3.6.1 milestone build.


Note You need to log in before you can comment on or make changes to this bug.