Bug 1273031 - USB Auto-Share is not working with spice-xpi
USB Auto-Share is not working with spice-xpi
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
x86_64 Linux
unspecified Severity high
: ovirt-3.6.1
: ---
Assigned To: Tomas Jelinek
sefi litmanovich
:
: 1274408 (view as bug list)
Depends On:
Blocks: 1274408
  Show dependency treegraph
 
Reported: 2015-10-19 08:30 EDT by Vaclav Ehrlich
Modified: 2016-10-04 00:03 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
USB Auto Share feature was not working when user used Browser plugin(ActiveX/XPI) as a console invocation method. This has been fixed
Story Points: ---
Clone Of:
: 1274408 (view as bug list)
Environment:
Last Closed: 2016-04-19 21:30:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spice-xpi log (3.06 KB, text/plain)
2015-10-19 08:32 EDT, Vaclav Ehrlich
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47856 None None None Never
oVirt gerrit 47963 ovirt-engine-3.6 MERGED userportal,webadmin: boolean params not always parsed well for browser plugins Never

  None (edit)
Description Vaclav Ehrlich 2015-10-19 08:30:30 EDT
Description of problem:
USB Auto Share is not working when user use Browser plugin as Console Invocation

Version-Release number of selected component (if applicable):
virt-viewer-2.0-6.el7.x86_64
spice-xpi-2.8-8.el7.x86_64
firefox-38.2.1-1.el7_1.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Log into RHEVM, prepare VM with USB redirect support, edit Console option for this VM (set Browser plugin and Enable USB Auto-Share)
2. Connect to VM
3. Plug USB into client

Actual results:
USB is not connected

Expected results:
USB is connected

Additional info:
Happen ONLY when 'Browser plugin' is used with Native client is everything OK.
Comment 1 Vaclav Ehrlich 2015-10-19 08:32 EDT
Created attachment 1084386 [details]
spice-xpi log
Comment 3 Christophe Fergeau 2015-10-20 05:02:54 EDT
Which RHEV version is this happening with? Was this broken with older libvirt versions too? Is this reproducible with the spice-xpi test page?
Comment 4 Vaclav Ehrlich 2015-10-21 09:29:09 EDT
rhevm version : 3.6.0.1-0.1
was this broken before ? according testing results no.
From spice-xpi test page it's working so I guess this bug is for wrong component.
Comment 5 Christophe Fergeau 2015-10-22 05:29:36 EDT
(In reply to Christophe Fergeau from comment #3)
> Was this broken with older libvirt versions too? 

Fwiw, I meant RHEV/oVirt here.

(In reply to Vaclav Ehrlich from comment #4)
> From spice-xpi test page it's working so I guess this bug is for wrong
> component.

Looks like it, I'll move it.
Comment 6 Christophe Fergeau 2015-10-22 05:30:06 EDT
This could be the same root cause as rhbz#1272181
Comment 7 Andrei Stepanov 2015-10-22 12:31:21 EDT
Also reproduces on:

Client:
spice-xpi-2.7-27.el6.i686
virt-viewer-2.0-7.el6.i686

Guest:
spice-vdagent-0.14.0-10.el7.x86_64

Rhev-m:
rhevm-userportal-3.6.0.1-0.1.el6.noarch
rhevm-webadmin-portal-3.6.0.1-0.1.el6.noarch
Comment 8 Christophe Fergeau 2015-10-22 12:35:57 EDT
*** Bug 1274408 has been marked as a duplicate of this bug. ***
Comment 9 Andrei Stepanov 2015-10-22 12:37:12 EDT
Bug does _not_ reproduce on the same client with RHEV-M 3.5:

Client:
spice-xpi-2.7-27.el6.i686
virt-viewer-2.0-7.el6.i686

RHEV-M:
rhevm-userportal-3.5.5-0.1.el6ev.noarch
rhevm-webadmin-portal-3.5.5-0.1.el6ev.noarch
Comment 10 sefi litmanovich 2015-12-10 04:50:18 EST
Verified on rhevm-3.6.1.2-0.1.el6.noarch:

Client:
spice-xpi-2.8.90-7.fc22.x86_64
virt-viewer-2.0-1.fc22.1.teuf.x86_64

Guest:
spice-vdagent-0.14.0-9.el7.x86_64

Rhev-m:
rhevm-userportal-3.6.1.2-0.1.el6.noarch
rhevm-webadmin-portal-3.6.1.2-0.1.el6.noarch

1. Create vm and install os (rhel 7.2).
2. install spice-vdagent
3. set vm to native usb support in engine->vm->menu
4. in vm->console-options set console invocation to 'Browser Plugin' and enable USB Auto-share.
5. open a console to vm (via firefox with spice-plugin).

Result:
USB device selection option is available on spice console.
usb stick connected to client as well as all other devices connected to slient via usb are detected and transferred successfully to guest.

Note You need to log in before you can comment on or make changes to this bug.