Bug 1273043 - Data Tiering:Lot of Promotions/Demotions failed error messages
Data Tiering:Lot of Promotions/Demotions failed error messages
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: bugs@gluster.org
bugs@gluster.org
: ZStream
Depends On: 1272398 1272409 1295700
Blocks: 1311865
  Show dependency treegraph
 
Reported: 2015-10-19 08:47 EDT by Dan Lambright
Modified: 2016-06-16 09:40 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1272409
: 1311865 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:40:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-10-19 09:05:09 EDT
REVIEW: http://review.gluster.org/12391 (cluster/tier remove suprious log messages on valid failed migration) posted (#1) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 2 Vijay Bellur 2015-10-19 12:56:17 EDT
COMMIT: http://review.gluster.org/12391 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit 116430b5e44457bba515a83be26b4b2256c75c38
Author: Dan Lambright <dlambrig@redhat.com>
Date:   Mon Oct 19 09:04:07 2015 -0400

    cluster/tier remove suprious log messages on valid failed migration
    
    On a write to a replica volume, we record in all brick's databases an entry.
    When the tier daemon runs, it will only move the file if it is the true
    owner of the file as defined by the XATTR_NODE_UUID_KEY.
    
    Change-Id: Ib82717f87a3f94f3d0d9f969773de9e88d6aaf22
    BUG: 1273043
    Signed-off-by: Dan Lambright <dlambrig@redhat.com>
    Reviewed-on: http://review.gluster.org/12391
    Reviewed-by: Joseph Fernandes
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 3 Vijay Bellur 2015-12-30 04:30:46 EST
REVIEW: http://review.gluster.org/13114 (cluster/tier: Additional details in error messages) posted (#1) for review on master by N Balachandran (nbalacha@redhat.com)
Comment 4 Nithya Balachandran 2015-12-30 04:32:09 EST
http://review.gluster.org/13114
adds additional information when available in log messages to help with debugging
Comment 5 Vijay Bellur 2016-01-04 02:02:13 EST
REVIEW: http://review.gluster.org/13114 (cluster/tier: Additional details in error messages) posted (#2) for review on master by N Balachandran (nbalacha@redhat.com)
Comment 6 Vijay Bellur 2016-01-04 10:20:04 EST
COMMIT: http://review.gluster.org/13114 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit 50d14b2aec654eaf95a467bc12a8c6fd396cfb0a
Author: N Balachandran <nbalacha@redhat.com>
Date:   Wed Dec 30 14:55:48 2015 +0530

    cluster/tier: Additional details in error messages
    
    Added file path/gfid when available to the tier log
    messages to make debugging easier.
    
    Change-Id: I22dda329367df2b846dcf254594312c997b66083
    BUG: 1273043
    Signed-off-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-on: http://review.gluster.org/13114
    Reviewed-by: mohammed rafi  kc <rkavunga@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 7 Niels de Vos 2016-06-16 09:40:47 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.