Bug 1311865 - Data Tiering:Lot of Promotions/Demotions failed error messages
Data Tiering:Lot of Promotions/Demotions failed error messages
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.8
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Nithya Balachandran
bugs@gluster.org
: Triaged, ZStream
Depends On: 1272398 1272409 1273043 1295700
Blocks: glusterfs-3.7.9
  Show dependency treegraph
 
Reported: 2016-02-25 03:58 EST by Nithya Balachandran
Modified: 2016-04-19 03:21 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1273043
Environment:
Last Closed: 2016-04-19 03:21:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-02-25 04:22:04 EST
REVIEW: http://review.gluster.org/13518 (cluster/tier: Additional details in error messages) posted (#1) for review on release-3.7 by N Balachandran (nbalacha@redhat.com)
Comment 2 Vijay Bellur 2016-03-07 17:15:59 EST
COMMIT: http://review.gluster.org/13518 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit e2f644b8d0ad3f729bfbae1322b6f3940fac8138
Author: N Balachandran <nbalacha@redhat.com>
Date:   Thu Feb 25 14:50:41 2016 +0530

    cluster/tier: Additional details in error messages
    
    Added file path/gfid when available to the tier log
    messages to make debugging easier.
    
    > Change-Id: I22dda329367df2b846dcf254594312c997b66083
    > BUG: 1273043
    > Signed-off-by: N Balachandran <nbalacha@redhat.com>
    > Reviewed-on: http://review.gluster.org/13114
    > Reviewed-by: mohammed rafi  kc <rkavunga@redhat.com>
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    > Tested-by: Dan Lambright <dlambrig@redhat.com>
    
    Change-Id: I5cbf8407fb7c493c4be1dda65c0f722ede33487f
    BUG: 1311865
    Signed-off-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-on: http://review.gluster.org/13518
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: mohammed rafi  kc <rkavunga@redhat.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 3 Kaushal 2016-04-19 03:21:27 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.