Bug 1273119 - Updated PackageKit cached metadata for Workstation live media
Updated PackageKit cached metadata for Workstation live media
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-19 12:23 EDT by Kalev Lember
Modified: 2015-10-31 22:32 EDT (History)
7 users (show)

See Also:
Fixed In Version: PackageKit-1.0.10-2.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-31 22:32:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kalev Lember 2015-10-19 12:23:22 EDT
A little bit of background first:

The Workstation images include a package called PackageKit-cached-metadata that ships a snapshot of yum repo metadata. This was done in order to make gnome-software initial experience better, so that it wouldn't have to go and download a huge amount of metadata just to be able to show what's currently installed in the system.

Normally, it's fine if the cached metadata package is a little bit behind, as gnome-software refreshes the metadata daily. 

However, this approach had some downsides. First, we normally don't keep the package up to date and only update it before the release. This means that during pre-release testing it is sometimes horribly out of date.

Secondly, shipping it in a subpackage of PackageKit means that whenever PackageKit is updated, post-GA, users also have to download a 100 MB cached metadata package update.

Third, the manual updating is time consuming to do manually and error prone. For example, last release we accidentally shipped x86_64 cached metadata for i686 images ...

These reports all stem from the fact that PackageKit-cached-metadata is out of date:

https://lists.fedoraproject.org/pipermail/test/2015-October/128127.html
https://bugzilla.redhat.com/show_bug.cgi?id=1264632
https://bugzilla.gnome.org/show_bug.cgi?id=755819

So, I talked to dgilmore about this today and we came up with a better solution, which is to automatically copy the metadata over from https://kojipkgs.fedoraproject.org/mash/ during image composes. I came up with a spin-kickstarts change, http://paste.fedoraproject.org/281027 that implements this. I would like to switch to the new approach for next TC/RC; as far as my testing goes, it's working as expected and much better than the previous approach. This change would involve:

1) applying http://paste.fedoraproject.org/281027 to spin-kickstarts
2) dropping PackageKit-cached-metadata from comps
3) doing a new PackageKit build that obsoletes and drops the PackageKit-cached-metadata subpackage

A test image that dgilmore built with the patch above is available at http://koji.fedoraproject.org/koji/taskinfo?taskID=11501773 if anyone wants to try booting it and seeing if gnome-software works.
Comment 1 Kalev Lember 2015-10-19 15:20:58 EDT
As per the discussion in the blocker review meeting, I've pushed the spin-kickstarts and comps fixes, and new PackageKit build is incoming:

https://git.fedorahosted.org/cgit/spin-kickstarts.git/commit/?h=f23&id=e07cfce2f1118a2052f91f6f5839657a73fd5a23

https://git.fedorahosted.org/cgit/comps.git/commit/?id=88768503288fd610cd1d648e6c1672473e6d0444
Comment 2 Fedora Update System 2015-10-19 15:23:14 EDT
PackageKit-1.0.10-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-f8475df681
Comment 3 Adam Williamson 2015-10-19 15:55:51 EDT
Discussed at 2015-10-19 blocker review meeting: https://meetbot.fedoraproject.org/fedora-blocker-review/2015-10-19/f23-blocker-review.2015-10-19-16.00.html .

During the meeting this was approved as an FE (but rejected as a blocker), but AIUI, we do not in fact need to pull PackageKit-1.0.10-2.fc23 through the freeze; 1) and 2) are sufficient to address this for the release images, and both changes have now been applied (and are just waiting on a mash). Thus I'm going to 'unpropose' this, so we don't pull PK through the freeze needlessly.

Please yell if that was wrong and we actually want to include PK in the frozen images.
Comment 4 Kamil Páral 2015-10-20 04:31:55 EDT
Seems to be working as intended.
Comment 5 Fedora Update System 2015-10-20 17:58:18 EDT
PackageKit-1.0.10-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update PackageKit'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-f8475df681
Comment 6 Fedora Update System 2015-10-31 22:32:56 EDT
PackageKit-1.0.10-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.