Bug 1273409 - RHEL OSP Director must be configure with nova-event-callback by default
RHEL OSP Director must be configure with nova-event-callback by default
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity urgent
: z3
: 7.0 (Kilo)
Assigned To: Lukas Bezdicka
Alexander Chuzhoy
: Triaged, ZStream
Depends On: 1264740 1298608
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-20 07:58 EDT by Mike Burns
Modified: 2016-01-14 09:49 EST (History)
18 users (show)

See Also:
Fixed In Version: openstack-puppet-modules-2015.1.8-31.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1264740
Environment:
Last Closed: 2015-12-21 12:11:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 235316 None None None Never

  None (edit)
Description Mike Burns 2015-10-20 07:58:14 EDT
Cloning for the OPM side

+++ This bug was initially created as a clone of Bug #1264740 +++

Description of problem:

Neutron is using nova event call-back to make sure neutron port is configured before VM is running

Both packstack and RHEL OSP installer are using it.

Configuration must be done on nova.conf and neutron.conf on contr


https://bugzilla.redhat.com/show_bug.cgi?id=1067211
https://blueprints.launchpad.net/neutron/+spec/nova-event-callback
https://blueprints.launchpad.net/nova/+spec/admin-event-callback-api


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Brent Eagles on 2015-09-21 13:30:15 EDT ---

Just a heads up that, if memory serves, that the nova part (vif_plugging_is_fatal = True) needs to be set to True on the compute nodes as well. The defaults would be preferable to what there is now. It seems that it might be being set to false in openstack-tripleo-heat-templates/puppet/hierdata/common.yaml - which might explain how this regression wheedled in.

The neutron config needs to have the appropriate entries to know "how to talk" to nova. The properties can be seen starting on line 331 or the sample neutron.conf on http://docs.openstack.org/kilo/config-reference/content/section_neutron.conf.html

I imagine that this stuff was configured in the installer version so it is probably just a matter of enabling it (openstack-puppet/modules/neutron/manifests/server/notifications.pp?) as long as nothing else gets in the way.

--- Additional comment from Brent Eagles on 2015-09-21 13:31:25 EDT ---

Forgot to mention that we probably should have an U/S bug on this once the details of the real culprits are figured out.

--- Additional comment from Emilien Macchi on 2015-09-21 13:53:03 EDT ---

Patch submitted upstream in TripleO Heat Templates: https://review.openstack.org/225962

--- Additional comment from James Slagle on 2015-10-07 16:03:31 EDT ---

note that vif_plugging_timeout also needs to use the default upstream value of 300 instead of the TripleO value of 30.

this has been pointed out on the above review as well

--- Additional comment from Nir Yechiel on 2015-10-08 02:50:59 EDT ---

Setting need-info on Emilien to get the team attention.

--- Additional comment from Emilien Macchi on 2015-10-13 12:29:13 EDT ---

Currently working on the undercloud part: https://review.openstack.org/234325
And also on the overcloud side: https://review.openstack.org/225962

--- Additional comment from Emilien Macchi on 2015-10-13 17:55:19 EDT ---

Undercloud: see the comment on https://review.openstack.org/234325 but we are blocked now without work in progress for the missing feature, I'm working on it with my team.

Overcloud: see the comment on https://review.openstack.org/225962 but we are also blocked, though there is some work in progress that we would depend on.

I'm not sure we can make it for Y2 but we will do our best.

--- Additional comment from Emilien Macchi on 2015-10-19 09:52:43 EDT ---

Just a quick update, I managed to unblock the situation.

If we have https://review.openstack.org/#/c/235316/ in OPM (should land soon upstream), we can configure nova-event-callback without managing Keystone resources with Puppet, which is a safer approach for Y2.

So:

* https://review.openstack.org/#/c/235316/ is about to be in OPM

* Undercloud patch: https://review.openstack.org/234325

* Overcloud patch: https://review.openstack.org/225962
Comment 2 Jaromir Coufal 2015-10-20 08:46:02 EDT
How does it look with the OPM build?
Comment 6 Alexander Chuzhoy 2015-12-07 16:14:27 EST
FailedQA:
Environment: openstack-puppet-modules-2015.1.8-31.el7ost.noarch


Based on comment #5:
[root@overcloud-controller-0 ~]# grep nova_admin_tenant_name /etc/neutron/neutron.conf
# nova_admin_tenant_name =
Comment 7 Mike Burns 2015-12-08 12:16:57 EST
Please retest when bug 1264740 goes back on_qa
Comment 8 Alexander Chuzhoy 2015-12-11 18:11:16 EST
FailedQA:
Environment: openstack-puppet-modules-2015.1.8-32.el7ost.noarch

Based on comment #5:
[root@overcloud-controller-0 ~]# grep nova_admin_tenant_name /etc/neutron/neutron.conf
# nova_admin_tenant_name =
Comment 9 Mike Burns 2015-12-14 08:34:07 EST
What THT was this tested with?  You need the fix from THT in order to test that setting. bug 1264740 has that fix.
Comment 10 Alexander Chuzhoy 2015-12-14 10:23:27 EST
Environment:
openstack-tripleo-heat-templates-0.8.6-92.el7ost.noarch
Comment 11 Mike Burns 2015-12-14 10:26:12 EST
lbezdick/emilien -- can you look and see where this is failing?
Comment 12 Lukas Bezdicka 2015-12-14 10:47:17 EST
Verification steps are wrong, the tripleo heat template is not setting nova_admin_tenant_name but tenant_name option which sets nova/tenant_name option. Check the [nova] section of the neutron.conf tenant_name=service
option is set.
Comment 13 Alexander Chuzhoy 2015-12-14 10:54:33 EST
Verified:

Verifying based on comment #12:

previously the line 'tenant_name=service' didn't exist in /etc/neutron/neutron.conf on controller(s), now it does.
Comment 15 errata-xmlrpc 2015-12-21 12:11:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2677

Note You need to log in before you can comment on or make changes to this bug.