Bug 1273448 - Need a new selinux policy type for 389-admin
Need a new selinux policy type for 389-admin
Status: CLOSED DUPLICATE of bug 1273451
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy (Show other bugs)
7.2
All All
unspecified Severity high
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-20 09:05 EDT by mreynolds
Modified: 2015-10-22 06:26 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-22 06:26:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mreynolds 2015-10-20 09:05:40 EDT
Need to introduce a new SELinux type for the 389-admin package's stop-ds-admin/start-ds-admin scripts to get httpd running as httpd_t.

---
From conversdation with Miroslav Grepl

type dirsrvadmin_initrc_exec_t;
init_script_file(dirsrvadmin_initrc_exec_t)


$ ls -lZ /usr/sbin/start-ds-admin
-rwxr-xr-x. root root system_u:object_r:dirsrvadmin_initrc_exec_t:s0
/usr/sbin/start-ds-admin
Comment 3 Miroslav Grepl 2015-10-22 06:26:56 EDT

*** This bug has been marked as a duplicate of bug 1273451 ***

Note You need to log in before you can comment on or make changes to this bug.