Bug 1273451 - Need a new selinux policy type for 389-admin
Need a new selinux policy type for 389-admin
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy (Show other bugs)
7.3
All All
medium Severity high
: rc
: ---
Assigned To: Lukas Vrabec
Eva Mrakova
:
: 1273448 (view as bug list)
Depends On:
Blocks: 1295396 1330851 1230240
  Show dependency treegraph
 
Reported: 2015-10-20 09:08 EDT by mreynolds
Modified: 2016-11-03 22:23 EDT (History)
10 users (show)

See Also:
Fixed In Version: selinux-policy-3.13.1-68.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1330851 (view as bug list)
Environment:
Last Closed: 2016-11-03 22:23:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mreynolds 2015-10-20 09:08:20 EDT
Need to introduce a new SELinux type for the 389-admin package's stop-ds-admin/start-ds-admin scripts to get httpd running as httpd_t.

---
From conversation with Miroslav Grepl

type dirsrvadmin_initrc_exec_t;
init_script_file(dirsrvadmin_initrc_exec_t)


$ ls -lZ /usr/sbin/start-ds-admin
-rwxr-xr-x. root root system_u:object_r:dirsrvadmin_initrc_exec_t:s0
/usr/sbin/start-ds-admin
Comment 4 Miroslav Grepl 2015-10-22 06:26:56 EDT
*** Bug 1273448 has been marked as a duplicate of this bug. ***
Comment 5 Miroslav Grepl 2016-01-14 04:58:20 EST
We already have

$ matchpathcon /usr/sbin/start-ds-admin
/usr/sbin/start-ds-admin	system_u:object_r:dirsrvadmin_exec_t:s0

in Fedora which needs to be back ported to RHEL.
Comment 6 Lukas Vrabec 2016-03-22 11:34:21 EDT
[root@ibm-x3250m4-15 ~]#  matchpathcon /usr/sbin/start-ds-admin
/usr/sbin/start-ds-admin	system_u:object_r:dirsrvadmin_exec_t:s0


Already fixed in RHEL.
Comment 12 errata-xmlrpc 2016-11-03 22:23:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2283.html

Note You need to log in before you can comment on or make changes to this bug.