Bug 1273551 - Restoring a RAM snapshots in RHEL7.2 shows error stating the vm (even though it starts correctly) and fails to connect via spice(SetVmTicket: Unexpected exception)
Restoring a RAM snapshots in RHEL7.2 shows error stating the vm (even though ...
Status: CLOSED CURRENTRELEASE
Product: vdsm
Classification: oVirt
Component: Core (Show other bugs)
4.16.27
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-3.5.6
: 4.16.28
Assigned To: Francesco Romani
Israel Pinto
virt
: Regression, ZStream
: 1278011 (view as bug list)
Depends On: 1260177
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-20 12:49 EDT by Francesco Romani
Modified: 2016-02-10 14:24 EST (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1260177
Environment:
Last Closed: 2015-12-22 08:24:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.5.z+
rule-engine: blocker+
ylavi: planning_ack+
michal.skrivanek: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
snapshot_log_engine_vdsm_qemu (76.17 KB, application/zip)
2015-11-05 09:59 EST, Israel Pinto
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 44842 None None None Never
oVirt gerrit 45979 None None None Never
oVirt gerrit 46524 None None None Never
oVirt gerrit 47487 ovirt-3.5 MERGED vm: graphics: fix settings after restore Never

  None (edit)
Comment 1 Red Hat Bugzilla Rules Engine 2015-10-20 12:49:56 EDT
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.
Comment 2 Red Hat Bugzilla Rules Engine 2015-10-22 10:47:59 EDT
Fixed bug tickets must have version flags set prior to fixing them. Please set the correct version flags and move the bugs back to the previous status after this is corrected.
Comment 3 Red Hat Bugzilla Rules Engine 2015-10-26 13:28:22 EDT
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 4 Israel Pinto 2015-11-05 09:58:20 EST
The problem with spice reproduce, can't open spice after start the vm with the preview memory snapshot.
Dialog window error:
Error while executing action SetVmTicket: Unexpected exception
envent log:
2015-Nov-05, 14:43:
user admin@internal failed to initiate a console session for VM test


Steps to Reproduce:
1. Create a VM with an OS, start it, make a snapshot and stop it.
2. start the vm and start a process (in my example: cat /dev/zero)
2. Create a RAM snapshot
3. Shutdown the vm
5. Preview the RAM snapshot
6. Start the vm with the preview snapshot


Setup:
Engine:3.5.6.2-0.1.el6ev
VDSM:vdsm-4.16.27-1.el7ev
libvirt:libvirt-1.2.17-13.el7  
spice: 0.12.4 - 15.el7

reopening the bug, adding logs
Comment 5 Red Hat Bugzilla Rules Engine 2015-11-05 09:58:24 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 6 Israel Pinto 2015-11-05 09:59 EST
Created attachment 1090137 [details]
snapshot_log_engine_vdsm_qemu
Comment 7 Francesco Romani 2015-11-09 09:03:36 EST
Unfortunately the fix didn't make in time for 4.16.27 and was merged in 4.16.28.
So it is definitely true that the bug still reproduces with VDSM < 4.16.28.
Please retry using VDSM >= 4.16.28.

Moving back to MODIFIED.
Comment 8 Eyal Edri 2015-11-09 10:56:47 EST
not a blocker and no respin is planned, moving to 3.5.7
Comment 9 Michal Skrivanek 2015-11-09 11:07:21 EST
(In reply to Francesco Romani from comment #7)
> Unfortunately the fix didn't make in time for 4.16.27 and was merged in
> 4.16.28.
> So it is definitely true that the bug still reproduces with VDSM < 4.16.28.
> Please retry using VDSM >= 4.16.28.
> 
> Moving back to MODIFIED.

it seems comment 4 was an incorrect setup, the right vdsm is indeed in vt18.2
Comment 10 Red Hat Bugzilla Rules Engine 2015-11-09 11:07:24 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 11 Michal Skrivanek 2015-11-09 11:08:17 EST
(In reply to Red Hat Bugzilla Rules Engine from comment #10)
> Bug tickets that are moved to testing must have target release set to make
> sure tester knows what to test. Please set the correct target release before
> moving to ON_QA.

AAAAAARGH!
Comment 12 Israel Pinto 2015-11-10 03:49:34 EST
Verify with:
Setup:
Engine:3.5.6.2-0.1.el6ev
VDSM: vdsm-4.16.29-1.el7ev.x86_64
libvirt: libvirt-1.2.17-13.el7
spice: 0.12.4 - 15.el7

Steps to Reproduce:
1. Create a VM with an OS, start it, make a snapshot and stop it.
2. start the vm and start a process (in my example: cat /dev/zero)
2. Create a RAM snapshot
3. Shutdown the vm
5. Preview the RAM snapshot
6. Start the vm with the preview snapshot
7. Start spice 

Results: Pass
Comment 13 Raz Tamir 2015-12-02 04:45:58 EST
*** Bug 1278011 has been marked as a duplicate of this bug. ***
Comment 14 Sandro Bonazzola 2015-12-22 08:24:26 EST
oVirt 3.5.6 has been released and the bz verified, moving to closed current release.

Note You need to log in before you can comment on or make changes to this bug.