Bug 1278011 - Restoring a RAM snapshots in RHEL7.2 shows error and fails to connect via spice (SetVmTicket: Unexpected exception)
Restoring a RAM snapshots in RHEL7.2 shows error and fails to connect via spi...
Status: CLOSED DUPLICATE of bug 1273551
Product: vdsm
Classification: oVirt
Component: Core (Show other bugs)
4.16.27
Unspecified Unspecified
unspecified Severity medium (vote)
: ---
: ---
Assigned To: Michal Skrivanek
Aharon Canan
virt
: Automation, Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-04 09:43 EST by Raz Tamir
Modified: 2015-12-02 04:45 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-02 04:45:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
engine and vdsm logs (138.40 KB, application/x-gzip)
2015-11-04 09:43 EST, Raz Tamir
no flags Details

  None (edit)
Description Raz Tamir 2015-11-04 09:43:07 EST
Created attachment 1089713 [details]
engine and vdsm logs

Description of problem:
Restoring a snapshot works but I cannot access via spice fails with "Error while executing action SetVmTicket: Unexpected exception". Also the engine shows an error starting the vm even though it starts successfully.

Version-Release number of selected component (if applicable):
libvirt-1.2.17-13.el7.x86_64
vdsm-4.16.28-1.el7ev.x86_64
rhevm-3.5.6.1-0.1.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Create a VM with an OS, start it, make a snapshot and stop it.
2. start the vm and start a process (in my example: cat /dev/zero)
2. Create a RAM snapshot
3. Shutdown the vm
5. Restore the RAM snapshot
6. Start the vm and open spice console

Actual results:


Expected results:


Additional info:
Comment 1 Tal Nisan 2015-11-04 12:01:56 EST
Raz, how is this storage related? I'd say it's more virt
Comment 2 Yaniv Kaul 2015-11-05 05:45:17 EST
Raz, are you sure the VM is properly up and running?

2015-11-03 22:24:13,346 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (DefaultQuartzScheduler_Worker-19) Correlation ID: null, Call Stack: null, Custom Event ID: -1, Message: VM vm_ram_snapshot_nfs is down with error. Exit message: Wake up from hibernation failed.
2015-11-03 22:24:13,347 INFO  [org.ovirt.engine.core.vdsbroker.VdsUpdateRunTimeInfo] (DefaultQuartzScheduler_Worker-19) Running on vds during rerun failed vm: null


Which VM is the problematic one in the logs?
Comment 3 Raz Tamir 2015-11-05 08:51:44 EST
Tal,
True.

Yaniv,
Yes, I successfully ssh to the vm to make sure the cat proc (step 2) is still running.
The problematic vm is vm ram_snapshot_nfs
Comment 4 Raz Tamir 2015-12-02 04:45:58 EST
Fixed in https://bugzilla.redhat.com/show_bug.cgi?id=1273551

*** This bug has been marked as a duplicate of bug 1273551 ***

Note You need to log in before you can comment on or make changes to this bug.