Bug 1273666 - sysfsutils missing from dependency list of openstack-nova
sysfsutils missing from dependency list of openstack-nova
Status: CLOSED DUPLICATE of bug 1288137
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
6.0 (Juno)
Unspecified Unspecified
high Severity high
: ---
: 8.0 (Liberty)
Assigned To: Lee Yarwood
nlevinki
: ZStream
Depends On:
Blocks: 1288141
  Show dependency treegraph
 
Reported: 2015-10-20 19:52 EDT by Bryan Yount
Modified: 2015-12-03 11:32 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1288141 (view as bug list)
Environment:
Last Closed: 2015-12-03 11:32:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 969433 None None None Never

  None (edit)
Description Bryan Yount 2015-10-20 19:52:58 EDT
Description of problem:
In a previous Bug 1114150 for OpenStack 4, sysfsutils was identified to be an important component of openstack-nova and Cinder and was included as a dependency of openstack-nova. However, the dependency appears to be missing in OpenStack 6. This caused an issue with a customer deployment of OSP 6.

Version-Release number of selected component (if applicable):
openstack-nova-compute.noarch 2014.2.3-31.el7ost

How reproducible:
Very

Steps to Reproduce:
1. Install OSP 6 using the OSP installer (Foreman)
2. Configure cinder storage using a fibre backend (3par in this case)
3. Try to attach a volume to an instance

Actual results:
Volume attach fails

Expected results:
Volume should properly attach

Additional info:
2015-10-19 11:22:15.904 36361 ERROR oslo.messaging._drivers.common [req-e690db45-797f-417b-9831-e7cc4e35c41d 7a817c88fdb947acbfb6e23c24bc23f6 128a36bbaf044826823c18f316e8dacc - - -] ['Traceback (most recent call last):\n', '  File "/usr/lib/python2.7/site-packages/oslo/messaging/rpc/dispatcher.py", line 134, in _dispatch_and_reply\n    incoming.message))\n', '  File "/usr/lib/python2.7/site-packages/oslo/messaging/rpc/dispatcher.py", line 177, in _dispatch\n    return self._do_dispatch(endpoint, method, ctxt, args)\n', '  File "/usr/lib/python2.7/site-packages/oslo/messaging/rpc/dispatcher.py", line 123, in _do_dispatch\n    result = getattr(endpoint, method)(ctxt, **new_args)\n', '  File "/usr/lib/python2.7/site-packages/osprofiler/profiler.py", line 105, in wrapper\n    return f(*args, **kwargs)\n', '  File "/usr/lib/python2.7/site-packages/cinder/volume/manager.py", line 895, in initialize_connection\n    raise exception.VolumeBackendAPIException(data=err_msg)\n', "VolumeBackendAPIException: Bad or unexpected response from the storage volume backend API: Unable to fetch connection information from backend: FibreChannelDriver validate_connector failed. No 'wwpns'. Make sure HBA state is Online.\n"]
Comment 4 Lee Yarwood 2015-12-03 11:32:46 EST
Merging with a similar sg3_utils dependency request for nova-compute.

*** This bug has been marked as a duplicate of bug 1288137 ***

Note You need to log in before you can comment on or make changes to this bug.