Bug 1273696 - Configuration for rsyslog server is not saved in /etc/rsyslog.conf file
Configuration for rsyslog server is not saved in /etc/rsyslog.conf file
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity high
: ovirt-3.6.1
: 3.6.1
Assigned To: Ryan Barry
wanghui
: EasyFix
Depends On:
Blocks: 985213
  Show dependency treegraph
 
Reported: 2015-10-21 00:53 EDT by wanghui
Modified: 2016-03-09 09:41 EST (History)
11 users (show)

See Also:
Fixed In Version: ovirt-node-3.3.0-0.18.20151022git82dc52c.el7ev
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 09:41:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47588 master MERGED Use the right Syslog class to do the configuration Never
oVirt gerrit 47611 ovirt-3.6 MERGED Use the right Syslog class to do the configuration Never

  None (edit)
Description wanghui 2015-10-21 00:53:27 EDT
Description of problem:
The configuration for rsyslog server through TUI is not saved in /etc/rsyslog.conf file.

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.2-20151009.0.iso
ovirt-node-3.3.0-0.13.20151008git03eefb5.el7ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install RHEV-H with network enabled.
2. Configure rsyslog server as 10.66.1.1 in TUI.
3. Check the /etc/rsyslog.conf file.

Actual results:
1. After step3, no infos about rsyslog server was added to 
/etc/rsyslog.conf file.

Expected results:
1. It should add as "*.* @@10.66.1.1:514" to /etc/rsyslog.conf file.

Additional info:
Comment 2 Ryan Barry 2015-10-21 10:41:34 EDT
Reverting that patch will cause regressions in multiple other bugs. Rsyslog does not work at all on EL7 without it.

I'm looking at the old patch, because I'm positive it got tested. There was a change at patch set 8 (after the last time I verified it) which moved all of the augeas logic to ovirt.node.utils.system, but it uses the same class name (Syslog) as ovirt.node.config.defaults, but this change was not reflected in config.defaults. It looks like the intention was to use utils.system.Rsyslog, but the class naming didn't reflect that, and rebasing the patch 9 months later missed the difference.

It's a one-line fix to use the actual logic, but note that "*.* @@some.host:514" will not work, since there were not (last time I checked) augeas lenses for tcp hosts (or ipv6 hosts), but udp will work fine, and that's the default configuration.
Comment 3 Fabian Deutsch 2015-10-21 14:28:32 EDT
The patch looks reasonable.

And keeping the patch open for 9 months - was just not the right way to handle it.

Merged it because it's an easy and low risk patch.
Comment 4 wanghui 2015-11-12 05:54:11 EST
Test version:
rhev-hypervisor-7-7.2-20151104.0.e17ev
ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch

Test step:
1. Install RHEV-H with network enabled.
2. Configure rsyslog server as 10.66.1.1 in TUI.
3. Check the /etc/rsyslog.conf file.

Test result:
1. Configuration is added in /etc/rsyslog.conf.
### end of the forwarding rule ###
*.*	@10.66.1.1:514

So this bug is fixed in ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch.
Comment 6 errata-xmlrpc 2016-03-09 09:41:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html

Note You need to log in before you can comment on or make changes to this bug.