Bug 985213 - Rsyslog doesn't work when using server's hostname as server address
Summary: Rsyslog doesn't work when using server's hostname as server address
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-node
Classification: oVirt
Component: General
Version: ---
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: ovirt-3.6.0-rc
: 3.3
Assignee: Ryan Barry
QA Contact: wanghui
URL:
Whiteboard: node
Keywords:
Depends On: 1273696
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-17 06:34 UTC by wanghui
Modified: 2016-02-10 12:52 UTC (History)
14 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-02-10 12:52:49 UTC
rbarry: needinfo-
rule-engine: ovirt-3.6.0+
ylavi: planning_ack+
rule-engine: devel_ack+
ycui: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 31531 master MERGED Don't write rsyslog.conf from a template Never

Comment 1 Fabian Deutsch 2013-11-28 14:39:28 UTC
Description of problem:
Rsyslog doesn't work when using server's hostname as server address.

Version-Release number of selected component (if applicable):
ovirt-node-iso-3.0.0-3.999.999.20130716190656git4e57356.2850.fc18.iso
ovirt-node-3.0.0-3.999.20130716190656git4e57356.fc18.noarch

How reproducible:
100%

Steps to Reproduce:
1. Clear install ovirt-node.
2. Configure network and change the dns server into 10.66.11.225 to resolve the hostname we set next.
3. Ping the server with its hostname.
4. Using hostname as rsyslog server address.
   Rsyslog is an enhanced multi-threaded syslogd
   Server Address:           example
   Server Port:              514
5. Check in remote rsyslog server.
   # nc -l -u 514
   In local host, run # echo "test" > /dev/kmsg

Actual results:
After step3, the server is reachable.
After step5, Rsyslog doesn't work.

Expected results:
After step5, Rsyslog works well.

Additional info:
1.No such issue when set Netconsole server address as the same hostname as we set in Rsyslog server.
2.When set rsyslog server with ip address(10.66.106.88), it can receive some messages from rhevh6.5, but also can not recevice the message using # echo "test" > /dev/kmsg command.

Comment 2 Sandro Bonazzola 2014-03-04 09:21:50 UTC
This is an automated message.
Re-targeting all non-blocker bugs still open on 3.4.0 to 3.4.1.

Comment 3 Sandro Bonazzola 2014-05-08 13:56:11 UTC
This is an automated message.

oVirt 3.4.1 has been released.
This issue has been retargeted to 3.5.0 since it has not been marked as high priority or severity issue, please retarget if needed.

Comment 4 Itamar Heim 2014-08-10 20:46:41 UTC
how is this an interesting use case in real life of deploying the node as the syslog server?

Comment 5 Ryan Barry 2014-08-11 16:06:55 UTC
IIUC, this is about using a hostname instead of an IP address in rsyslog.conf rather than using Node as a syslog server

This isn't reproducable on current EL6 images, but is on EL7, as rsyslog.conf is missing a directive to load the module for journald

Comment 6 Doron Fediuck 2014-09-04 10:32:50 UTC
Itamar, see comment 5.

Comment 9 Red Hat Bugzilla Rules Engine 2015-10-18 08:34:47 UTC
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.

Comment 10 wanghui 2016-02-03 06:21:59 UTC
Test version:
rhev-hypervisor7-7.2-20160126.0
ovirt-node-3.6.1-5.0.el7ev.noarch

Test steps:
1. Clean install rhev-hypervisor7-7.2-20160126.0.
2. Configure network and change the dns serverto resolve the hostname we set next.
3. Ping the server with its hostname.
4. Using hostname as rsyslog server address.
   Rsyslog is an enhanced multi-threaded syslogd
   Server Address:           example
   Server Port:              514
5. Check in remote rsyslog server.
   # nc -l -u 514
   In local host, run # echo "test" > /dev/kmsg

Test result:
1. After step5, Rsyslog works well.

So this issue is fixed in ovirt-node-3.6.1-5.0.el7ev.noarch. Change the status to verified.


Note You need to log in before you can comment on or make changes to this bug.