Bug 1273704 - [userinterface_public_543]Could not see replica numbers in the chart on IE11 and Safari of IPad/Iphone
[userinterface_public_543]Could not see replica numbers in the chart on IE11 ...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Management Console (Show other bugs)
3.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Samuel Padgett
yapei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-21 01:22 EDT by Wei Sun
Modified: 2015-11-23 16:13 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 16:13:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
IE11 chart (32.80 KB, image/png)
2015-10-21 01:25 EDT, Wei Sun
no flags Details
Safari of IPad/Iphone (69.94 KB, image/png)
2015-10-21 01:28 EDT, Wei Sun
no flags Details
Problem using patternfly donut charts on IE (67.94 KB, image/png)
2015-10-21 17:25 EDT, Samuel Padgett
no flags Details

  None (edit)
Description Wei Sun 2015-10-21 01:22:43 EDT
Description of problem:
Create an application and access the overview page,on IE11 and Safari of IPad/Iphone,we could not see replica numbers in the chart.

Please refer to the attachment

Version-Release number of selected component (if applicable):
devenv-rhel_2504

How reproducible:
Always

Steps to Reproduce:
1.Create an application
2.After builds completes,check the overview pages using IE11 or Safari of Ipad/Iphone


Actual results:
Could not see replica numbers in the chart

Expected results:
Should see replica numbers in the chart

Additional info:
It works well for Firefox and Chrome
It also works well for Safari of Mac
Comment 1 Wei Sun 2015-10-21 01:25 EDT
Created attachment 1084978 [details]
IE11 chart
Comment 2 Wei Sun 2015-10-21 01:28 EDT
Created attachment 1084979 [details]
Safari of IPad/Iphone
Comment 3 Samuel Padgett 2015-10-21 15:43:04 EDT
I've reproduced this on IE.
Comment 4 Samuel Padgett 2015-10-21 17:24:48 EDT
The patternfly donut chart has the problem. See this page in IE:

http://angular-patternfly.rhcloud.com/#/api/patternfly.charts.directive:pfDonutPctChart

Nothing appears in any of the donuts. This will be a problem for the metrics utilization charts, too. Jessica, FYI.
Comment 5 Samuel Padgett 2015-10-21 17:25 EDT
Created attachment 1085334 [details]
Problem using patternfly donut charts on IE
Comment 6 Samuel Padgett 2015-10-21 20:38:33 EDT
Patternfly is inserting HTML markup inside an SVG <text> element, which from what I can tell isn't allowed (although seems to work in some browsers).
Comment 7 Samuel Padgett 2015-10-21 20:54:37 EDT
I might have spoken too soon. It looks like <tspan> is OK.
Comment 8 Samuel Padgett 2015-10-21 21:32:03 EDT
I have a fix for the overview.

https://github.com/openshift/origin/pull/5309
Comment 9 Wei Sun 2015-10-23 01:30:29 EDT
Verified on devenv-rhel7_2529

Now could see the replica numbers in donut chart using IE11 or Safari of Ipad/Iphone.

Note You need to log in before you can comment on or make changes to this bug.