Bug 1273722 - [RFE]: [SNAPSHOT]: Deleting a clone should remove the entries from /run/gluster/snaps and should not be mounted.
[RFE]: [SNAPSHOT]: Deleting a clone should remove the entries from /run/glust...
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: snapshot (Show other bugs)
3.1
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: rjoseph
storage-qa-internal@redhat.com
: FutureFeature, ZStream
: 1273716 (view as bug list)
Depends On:
Blocks: 1268895
  Show dependency treegraph
 
Reported: 2015-10-21 02:26 EDT by Shashank Raj
Modified: 2016-11-07 22:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-18 02:22:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shashank Raj 2015-10-21 02:26:06 EDT
Description of problem:

Whenever we delete a snapshot-clone, the entries of clones under /run/gluster/snaps doesn't get deleted. and we have to manually clean up the system.

Version-Release number of selected component (if applicable):
glusterfs-3.7.5-0.3

How reproducible:
Always

Steps to Reproduce:
1.Craete a volume and then a snapshot of it.
2.Create a clone of this snapshot.
3.Delete the clone using volume delete command.
4.Observe that after deleting the clones, the entries for clones still persists inside /run/gluster/snaps and it still shows as mounted.
5. We have to manually delete the entries and clean up the system.

Actual results:
Clone entries under /run/gluster/snaps doesn't get deleted and clone still shows as mounted.


Expected results:
Clone entries should be removed from /run/gluster/snaps and it should get umounted.


Additional info:
Comment 2 Avra Sengupta 2016-07-14 05:17:30 EDT
*** Bug 1273716 has been marked as a duplicate of this bug. ***
Comment 3 Avra Sengupta 2016-07-14 05:21:51 EDT
*** Bug 1309209 has been marked as a duplicate of this bug. ***
Comment 4 Avra Sengupta 2016-10-18 02:22:35 EDT
A cloned snapshot, is similar to a gluster volume, and hence following the same protocol, will not clear it's entries itself. The issue of not being able to create clone with the same name will be handled as part of https://bugzilla.redhat.com/show_bug.cgi?id=1309209

Note You need to log in before you can comment on or make changes to this bug.