Bug 1309209 - clone creation with older names in a system fails
clone creation with older names in a system fails
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: snapshot (Show other bugs)
3.1
All Linux
unspecified Severity high
: ---
: RHGS 3.3.0
Assigned To: Avra Sengupta
Anil Shah
: Reopened, ZStream
: 1408386 (view as bug list)
Depends On:
Blocks: 1268895 1387160 1417147
  Show dependency treegraph
 
Reported: 2016-02-17 03:18 EST by Shashank Raj
Modified: 2017-09-21 00:53 EDT (History)
14 users (show)

See Also:
Fixed In Version: glusterfs-3.8.4-19
Doc Type: Bug Fix
Doc Text:
The names and locations of previously cloned and deleted volumes were not cleaned up correctly. This meant that creating a clone with the same name as a previously deleted clone failed with a 'Commit failed' message. Cleanup is now handled correctly and the same name can be used for a clone in this situation.
Story Points: ---
Clone Of:
: 1387160 (view as bug list)
Environment:
Last Closed: 2017-09-21 00:25:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shashank Raj 2016-02-17 03:18:53 EST
Description of problem:

Whenever we are creating a clone with a name that's already been a part of a system as cloned volume before (but its deleted now), it fails with "Commit failed" message. For this to work properly, user need to remove the entries of older cloned volume from /run/gluster/snaps and and unmount it.

Document URL: 

Section Number and Name: 

Describe the issue:

1.Create a clone with a name that was already a part of the system (but deleted now). However its entries can be seen under /run/gluster/snaps and it will be mounted.
2.this creation fails with commit failed message.
3.Remove the cloned volume entries from /run/gluster/snaps and unmount the clone.
4.Try the clone creation again with the same name and it should pass after removing the entries. 

Suggestions for improvement: 

Additional information:
Comment 3 Avra Sengupta 2016-02-19 03:04:56 EST
Thanks Laura. It's perfect.
Comment 5 Avra Sengupta 2016-07-14 05:21:51 EDT
The issue is same as 1273722 and will be fixed as part of 1273722

*** This bug has been marked as a duplicate of bug 1273722 ***
Comment 7 Avra Sengupta 2016-10-18 02:21:19 EDT
This has been marked as duplicate by mistake. This needs to be fixed.
Comment 8 Avra Sengupta 2016-10-20 05:32:04 EDT
Patch posted upstream master : http://review.gluster.org/15683
Comment 10 Avra Sengupta 2016-12-23 04:41:38 EST
*** Bug 1408386 has been marked as a duplicate of this bug. ***
Comment 13 Atin Mukherjee 2017-03-24 04:43:33 EDT
downstream patch : https://code.engineering.redhat.com/gerrit/#/c/101285
Comment 15 Anil Shah 2017-05-02 06:05:06 EDT
[root@rhs-arch-srv1 yum.repos.d]# gluster snapshot clone clone1 snap0
snapshot clone: success: Clone clone1 created successfully
[root@rhs-arch-srv1 yum.repos.d]# gluster v list
clone1
gluster_shared_storage
newvolume
vol0
vol1
[root@rhs-arch-srv1 yum.repos.d]# gluster v start clone1
volume start: clone1: success
[root@rhs-arch-srv1 yum.repos.d]# gluster v stop clone1
Stopping volume will make its data inaccessible. Do you want to continue? (y/n) y
gluster v delete clone1volume stop: clone1: success
[root@rhs-arch-srv1 yum.repos.d]# gluster v delete clone1
Deleting volume will erase all information about the volume. Do you want to continue? (y/n) y
volume delete: clone1: success
[root@rhs-arch-srv1 yum.repos.d]# gluster v list
gluster_shared_storage
newvolume
vol0
vol1
[root@rhs-arch-srv1 yum.repos.d]# gluster snapshot list vol1
snap0_GMT-2017.05.02-06.35.44
snap0
snap1
snap1-2
[root@rhs-arch-srv1 yum.repos.d]# gluster snapshot clone clone1 snap0
snapshot clone: success: Clone clone1 created successfully
[root@rhs-arch-srv1 yum.repos.d]# gluster v start clone1
volume start: clone1: success
[root@rhs-arch-srv1 yum.repos.d]# 

Can create clones with same name as previous deleted clone.
Bug verified on build glusterfs-3.8.4-24.el7rhgs.x86_64
Comment 19 errata-xmlrpc 2017-09-21 00:25:52 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2774
Comment 20 errata-xmlrpc 2017-09-21 00:53:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2774

Note You need to log in before you can comment on or make changes to this bug.