This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1273828 - [hosted-engine-setup] [iSCSI support] The LUN where the HE iSCSI domain resides on should be removed from engine DB during upgrade from 3.5 to 3.6
[hosted-engine-setup] [iSCSI support] The LUN where the HE iSCSI domain resid...
Status: CLOSED DUPLICATE of bug 1273779
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: Plugins.Block (Show other bugs)
1.3.0
x86_64 Unspecified
unspecified Severity high (vote)
: ---
: ---
Assigned To: Simone Tiraboschi
Ilanit Stein
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-21 06:52 EDT by Elad
Modified: 2015-10-21 07:27 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-21 07:27:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ebenahar: planning_ack?
ebenahar: devel_ack?
ebenahar: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Elad 2015-10-21 06:52:50 EDT
Description of problem:
For now, once 3.5 hosted-engine is deployed over iSCSI, the LUN where the HE domain resides on, gets written in the engine DB as a direct LUN. 
This LUN should get cleaned from the DB during upgrade to 3.6 since in 3.6, the HE domain gets imported to the setup and it's not importable in case its LUN is in the DB.

Version-Release number of selected component (if applicable):
Always

How reproducible:
ovirt-hosted-engine-setup-1.3.0-1.el7ev.noarch

Steps to Reproduce:
1. Deploy 3.5 HE over iSCSI 
2. Upgrade the setup to 3.6


Actual results:
The LUN of the HE domain is not removed from the DB

Expected results:
The LUN should get removed during the upgrade
Comment 1 Simone Tiraboschi 2015-10-21 07:27:18 EDT

*** This bug has been marked as a duplicate of bug 1273779 ***

Note You need to log in before you can comment on or make changes to this bug.