Bug 1273779 - [hosted-engine-setup] [iscsi] Cannot import the hosted-engine storage domain after 3.5 -> 3.6 upgrade because its LUN was written in the engine DB as a direct LUN
Summary: [hosted-engine-setup] [iscsi] Cannot import the hosted-engine storage domain ...
Keywords:
Status: CLOSED DUPLICATE of bug 1273378
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.HostedEngine
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent vote
Target Milestone: ovirt-3.6.1
: ---
Assignee: Roy Golan
QA Contact: Ilanit Stein
URL:
Whiteboard: sla
: 1273828 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-21 08:31 UTC by Simone Tiraboschi
Modified: 2016-02-10 19:19 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-09 13:15:17 UTC
oVirt Team: SLA
sbonazzo: ovirt-3.6.z?
rule-engine: planning_ack?
dfediuck: devel_ack+
rule-engine: testing_ack?


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1269768 0 urgent CLOSED Auto import hosted engine domain 2021-02-22 00:41:40 UTC

Internal Links: 1269768

Description Simone Tiraboschi 2015-10-21 08:31:16 UTC
Description of problem:
In oVirt 3.5 the iSCSI LUN used to deploy hosted-engine was added to the engine DB as a fake direct LUN to mark it as used and prevent any misuse that could destroy the whole engine (see https://bugzilla.redhat.com/show_bug.cgi?id=1157238 ).

On 3.6 we are able to properly handle the hosted-engine storage domain and so the engine automatically tries to import it.

https://gerrit.ovirt.org/#/c/47508/ solves it for new deployment avoid to add it as a fake direct LUN but we have still to handle 3.5 -> 3.6 upgrade for iSCSI deployments.

On 3.5 -> 3.6 upgrade the user doesn't need to run hosted-engine-setup and the hosted-engine HA agent doesn't know the admin password to do it vi REST API.

So we can fix it:
1. in engine-setup upgrading the engine from 3.5 to 3.6
2. in the engine when the engine tries to auto-import the hosted-engine storage domain.

Personally I'm for option 2.

Version-Release number of selected component (if applicable):
1.3.0

How reproducible:
100%

Steps to Reproduce:
1. deploy hosted-engine from 3.5 on iSCSI
2. upgrade to 3.6
3.

Actual results:
The hosted-engine LUN is still a fake Direct LUN

Expected results:
Hosted-engine storage domain appears in the engine 

Additional info:

Comment 1 Simone Tiraboschi 2015-10-21 11:27:18 UTC
*** Bug 1273828 has been marked as a duplicate of this bug. ***

Comment 2 Roy Golan 2015-10-21 14:27:54 UTC
we need to add to the auto import code the removal of the direct lun (if exist). This means to cancel the CanDoAction when removing the hosted engine direct lun disk - RemoveDiskCommand

Comment 3 Yaniv Lavi 2015-10-29 12:48:52 UTC
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.

Comment 4 Yaniv Lavi 2015-12-01 12:20:12 UTC
Is this going to be in this week as well?

Comment 5 Roy Golan 2015-12-09 13:15:17 UTC

*** This bug has been marked as a duplicate of bug 1273378 ***


Note You need to log in before you can comment on or make changes to this bug.