Bug 1273930 - set vmpool type
set vmpool type
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine-sdk-python
Classification: oVirt
Component: General (Show other bugs)
3.5.1.0
x86_64 Linux
unspecified Severity medium (vote)
: ovirt-3.6.0-rc3
: 3.5.6.0
Assigned To: Juan Hernández
Karolína Hajná
infra
:
Depends On: 1244841 1286683
Blocks: 1275984 1275987
  Show dependency treegraph
 
Reported: 2015-10-21 10:11 EDT by Anton Chernomaz
Modified: 2016-05-19 21:23 EDT (History)
3 users (show)

See Also:
Fixed In Version: ovirt-engine-sdk-python-3.5.6.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1275984 1275987 (view as bug list)
Environment:
Last Closed: 2015-11-27 02:57:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
juan.hernandez: ovirt‑3.6.0?
rule-engine: planning_ack?
juan.hernandez: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)

  None (edit)
Description Anton Chernomaz 2015-10-21 10:11:11 EDT
Description of problem:
I need to set vmpool type to manual ( can do this via webui ) and fail to find any trace in documentation
please assist


Version-Release number of selected component (if applicable):
i am using : ovirt-engine-sdk-python 3.5.1.0
and ovirt oVirt Engine Version: 3.5.2.1-1.el6

How reproducible:
 src_tpl = api.vmpools.add(params.VmPool(
                                            name = poolname,
                                            template = params.Template(id=templateid),
                                            cluster = params.Cluster(id=clusterid),
                                            size = int(numvm),
                                            description = desc,
                                            max_user_vms = 1
                                            )
                            )


Steps to Reproduce:
1.
2.
3.

Actual results:
always get automatic pool type

Expected results:
would like to know what params. need to use as failed to find in documentation

Additional info:
Comment 1 Juan Hernández 2015-10-21 10:20:32 EDT
Currently this is impossible. It will be possible starting with version 3.5.6, see bug 1244841.
Comment 2 Red Hat Bugzilla Rules Engine 2015-11-02 07:27:02 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 3 Karolína Hajná 2015-11-10 06:45:33 EST
Verified on rhevm-sdk-python-3.5.6.0-1.el6ev.noarch
Comment 4 Sandro Bonazzola 2015-11-27 02:57:06 EST
Since oVirt 3.6.0 has been released, moving from verified to closed current release.

Note You need to log in before you can comment on or make changes to this bug.