Bug 1275984 - [REGENERATE PYTHON SDK] set vmpool type
[REGENERATE PYTHON SDK] set vmpool type
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-sdk (Show other bugs)
3.6.0
x86_64 Linux
unspecified Severity medium
: ovirt-3.5.6
: 3.5.6
Assigned To: Juan Hernández
Gonza
infra
: Rebase, ZStream
Depends On: 1244841 1273930 1286683
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-28 05:47 EDT by Juan Hernández
Modified: 2016-02-10 14:14 EST (History)
12 users (show)

See Also:
Fixed In Version: rhevm-sdk-python-3.5.6.0-1
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of: 1273930
Environment:
Last Closed: 2015-12-01 14:05:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juan Hernández 2015-10-28 05:47:29 EDT
+++ This bug was initially created as a clone of Bug #1273930 +++

Description of problem:
I need to set vmpool type to manual ( can do this via webui ) and fail to find any trace in documentation
please assist


Version-Release number of selected component (if applicable):
i am using : ovirt-engine-sdk-python 3.5.1.0
and ovirt oVirt Engine Version: 3.5.2.1-1.el6

How reproducible:
 src_tpl = api.vmpools.add(params.VmPool(
                                            name = poolname,
                                            template = params.Template(id=templateid),
                                            cluster = params.Cluster(id=clusterid),
                                            size = int(numvm),
                                            description = desc,
                                            max_user_vms = 1
                                            )
                            )


Steps to Reproduce:
1.
2.
3.

Actual results:
always get automatic pool type

Expected results:
would like to know what params. need to use as failed to find in documentation

Additional info:

--- Additional comment from Juan Hernández on 2015-10-21 10:20:32 EDT ---

Currently this is impossible. It will be possible starting with version 3.5.6, see bug 1244841.
Comment 2 Gonza 2015-11-09 10:28:30 EST
Verified with:
rhevm-sdk-python-3.5.6.0-1.el6ev.noarch

src_tpl = api.vmpools.add(params.VmPool(
...     name="API_vm_pool",
...     template=params.Template(id=test_template.id),
...     cluster=params.Cluster(id=test_cluster.id),
...     size=2,
...     description="api vm pool from api",
...     max_user_vms=1,
...     type_="MANUAL"))
Comment 4 errata-xmlrpc 2015-12-01 14:05:33 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2532.html

Note You need to log in before you can comment on or make changes to this bug.