Bug 1273936 - [CI] Increasing again timeouts to avoid false positives on CI jobs
[CI] Increasing again timeouts to avoid false positives on CI jobs
Status: CLOSED DUPLICATE of bug 1273937
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: Plugins.General (Show other bugs)
1.3.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Sandro Bonazzola
Ilanit Stein
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-21 10:26 EDT by Simone Tiraboschi
Modified: 2015-10-21 10:34 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-21 10:34:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Simone Tiraboschi 2015-10-21 10:26:53 EDT
Description of problem:
Starting VM and setting its console ticket are async operations.
Hosted-engine-setup is doing that via VDSM and then is polling to check the result till an explicit exit status (success/failure) or a timeout to avoid getting stuck indefinitely.
We are seeing false positives on CI jobs (which run on an overloaded environment which is by far slower than a real environment) due to that timeout as for
http://jenkins-ci.eng.lab.tlv.redhat.com/job/hosted_engine_3.6_el7_staticip_nfs3_install_on_7.1/126

So let's increase its value.
 

Version-Release number of selected component (if applicable):
hosted-engine-setup 1.3

How reproducible:
seldom, you must it the timeout on a really overloaded system.
Never seen on real deployiment

Steps to Reproduce:
1. launch hosted-engine --deploy
2.
3.

Actual results:
It can fail with 'The VM is not powering up: please check VDSM logs' while the engine VM simply started a few seconds after that

Expected results:
It should wait a bit more

Additional info:
Comment 1 Simone Tiraboschi 2015-10-21 10:34:15 EDT

*** This bug has been marked as a duplicate of bug 1273937 ***

Note You need to log in before you can comment on or make changes to this bug.