Bug 1273937 - [CI] Increasing again timeouts to avoid false positives on CI jobs
[CI] Increasing again timeouts to avoid false positives on CI jobs
Status: CLOSED CURRENTRELEASE
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: Plugins.General (Show other bugs)
1.3.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-3.6.1
: 1.3.1
Assigned To: Sandro Bonazzola
Artyom
integration
: AutomationBlocker, ZStream
: 1273936 (view as bug list)
Depends On:
Blocks: 1284979
  Show dependency treegraph
 
Reported: 2015-10-21 10:27 EDT by Simone Tiraboschi
Modified: 2015-12-16 07:22 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 07:22:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
ylavi: planning_ack+
sbonazzo: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47586 master MERGED packaging: setup: increase VM startup and ticket setting timeout Never
oVirt gerrit 47587 ovirt-hosted-engine-setup-1.3 MERGED packaging: setup: increase VM startup and ticket setting timeout Never

  None (edit)
Description Simone Tiraboschi 2015-10-21 10:27:29 EDT
Description of problem:
Starting VM and setting its console ticket are async operations.
Hosted-engine-setup is doing that via VDSM and then is polling to check the result till an explicit exit status (success/failure) or a timeout to avoid getting stuck indefinitely.
We are seeing false positives on CI jobs (which run on an overloaded environment which is by far slower than a real environment) due to that timeout as for
http://jenkins-ci.eng.lab.tlv.redhat.com/job/hosted_engine_3.6_el7_staticip_nfs3_install_on_7.1/126

So let's increase its value.
 

Version-Release number of selected component (if applicable):
hosted-engine-setup 1.3

How reproducible:
seldom, you must it the timeout on a really overloaded system.
Never seen on real deployiment

Steps to Reproduce:
1. launch hosted-engine --deploy
2.
3.

Actual results:
It can fail with 'The VM is not powering up: please check VDSM logs' while the engine VM simply started a few seconds after that

Expected results:
It should wait a bit more

Additional info:
Comment 1 Simone Tiraboschi 2015-10-21 10:34:15 EDT
*** Bug 1273936 has been marked as a duplicate of this bug. ***
Comment 2 Artyom 2015-11-26 10:31:54 EST
Verified on ovirt-hosted-engine-setup-1.3.1-1.el7ev.noarch according to http://jenkins-ci.eng.lab.tlv.redhat.com/job/hosted_engine_3.6_el7_staticip_nfs3_install_on_7.1
Comment 3 Sandro Bonazzola 2015-12-16 07:22:47 EST
According to verification status and target milestone this issue should be fixed in oVirt 3.6.1. Closing current release.

Note You need to log in before you can comment on or make changes to this bug.