Bug 1273970 - Automation of UI tests needs way to check status of VM in userportal
Automation of UI tests needs way to check status of VM in userportal
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.UserPortal (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity high (vote)
: ovirt-4.0.0-alpha
: 4.0.0
Assigned To: Greg Sheremeta
Petr Matyáš
: AutomationBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-21 11:33 EDT by movciari
Modified: 2016-07-05 03:38 EDT (History)
10 users (show)

See Also:
Fixed In Version: ovirt 4.0.0 alpha1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-05 03:38:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
rule-engine: exception+
mgoldboi: planning_ack+
rule-engine: devel_ack+
pnovotny: testing_ack+


Attachments (Terms of Use)
screen: User Portal - Extended; missing "data-status" attribute for VM status (180.36 KB, image/png)
2016-01-11 13:28 EST, Pavel Novotny
no flags Details
userportal fixed (43.42 KB, image/png)
2016-03-16 14:40 EDT, Greg Sheremeta
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48566 master MERGED userportal, webadmin: added data-status attr for automation Never
oVirt gerrit 49602 ovirt-engine-3.6 MERGED userportal, webadmin: added data-status attr for automation Never
oVirt gerrit 54842 master MERGED userportal: added data-status attr for automation 2016-03-18 11:31 EDT
oVirt gerrit 54947 ovirt-engine-3.6 MERGED userportal: added data-status attr for automation 2016-03-21 17:13 EDT

  None (edit)
Description movciari 2015-10-21 11:33:28 EDT
Description of problem:
In ovirt 3.5 we used tooltip of status icon to find out what's the status of VM according to userportal, and currently we have no reasonable way for our automation to find out what status is being shown by userportal in 3.6.

Solution could be for example to add the column showing status of VM as text, similar to status column in webadmin, or to add some data attribute containing status of VM

Version-Release number of selected component (if applicable):
3.6.0-0.18.el6

How reproducible:
always
Comment 1 Einav Cohen 2015-10-22 08:35:48 EDT
need to see if solution for bug 1273962 (if/once found) can be applied here as well. 
if not - I may defer to the 'virt' team in order to add the status text somewhere.
Comment 2 Red Hat Bugzilla Rules Engine 2015-10-22 08:35:55 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 3 Einav Cohen 2015-10-22 08:37:22 EDT
due to being automation blocker and high severity, will try to fix for 3.6.z.
Comment 4 vszocs 2015-10-23 12:06:02 EDT
(In reply to Einav Cohen from comment #1)
> need to see if solution for bug 1273962 (if/once found) can be applied here
> as well.

I believe it can be applied here too.

Please see my comment https://bugzilla.redhat.com/show_bug.cgi?id=1273962#c1
Comment 5 Yaniv Lavi 2015-10-29 08:50:12 EDT
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.
Comment 6 Einav Cohen 2015-11-18 10:54:15 EST
Greg: BZ is flagged/targeted for ovirt 3.6, however I don't see that the patch has been backported to the ovirt-engine-3.6 branch - let's backport the patch to the following branches: 
- ovirt-engine-3.6
- ovirt-engine-3.6.1 , if exists (I updated the Target Milestone from ovirt-3.6.3 to ovirt-3.6.1). 

Thanks.
Comment 7 Greg Sheremeta 2015-12-02 14:35:46 EST
backported to ovirt-engine-3.6
Comment 8 Sandro Bonazzola 2015-12-23 08:40:26 EST
oVirt 3.6.2 RC1 has been released for testing, moving to ON_QA
Comment 9 Pavel Novotny 2016-01-11 13:25:47 EST
FailedQA in rhevm-userportal-3.6.2-0.1.el6 (build 3.6.2-3).

New "data-status" attribute has been added to VM status icon column only in Webadmin.

The attribute is missing especially in User Portal - Extended view, where our test automation has problem to extract VM status from HTML code. Screen shot attached.
Comment 10 Red Hat Bugzilla Rules Engine 2016-01-11 13:25:50 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 11 Pavel Novotny 2016-01-11 13:28 EST
Created attachment 1113647 [details]
screen: User Portal - Extended; missing "data-status" attribute for VM status
Comment 17 Greg Sheremeta 2016-02-07 18:48:49 EST
Deferring to 3.6.5. It's too risky to try to get this into 3.6.3 or 3.6.4.
Comment 18 Michal Skrivanek 2016-02-11 07:15:15 EST
Moreover it caused a regression bug 1304729
Comment 19 Yaniv Kaul 2016-03-14 07:19:01 EDT
oved - are we going to fix or WONTFIX this?
Comment 20 Greg Sheremeta 2016-03-16 14:07:55 EDT
I think this should be fixed. Looking at it now.
Comment 21 Greg Sheremeta 2016-03-16 14:40:31 EDT
The userportal fix actually wasn't as difficult as I first thought.

@Oved, we may want to re-evaluate whether this goes into 3.6.5. This will only help QE in 3.6.z going forward.
Comment 22 Greg Sheremeta 2016-03-16 14:40 EDT
Created attachment 1137126 [details]
userportal fixed
Comment 23 Greg Sheremeta 2016-03-18 11:33:31 EDT
Fix is merged in master.

@Pavel, do you need this in 3.6.z?
Comment 24 Pavel Novotny 2016-03-18 12:30:44 EDT
(In reply to Greg Sheremeta from comment #23)
> Fix is merged in master.
> 
> @Pavel, do you need this in 3.6.z?

Yes, if possible, we would like to have it also in 3.6.z.
Comment 25 Pavel Novotny 2016-03-18 12:32:58 EDT
Restoring Greg's needinfo for Oved from comment 21.
Comment 26 Greg Sheremeta 2016-03-18 14:23:40 EDT
The backport was clean and easy. Let's get it into 3.6.5 as we originally planned.
Comment 27 Oved Ourfali 2016-03-28 07:20:21 EDT
Removing needinfo.
Comment 28 Petr Matyáš 2016-05-05 11:37:14 EDT
Verified on RHEV 3.6.6 and oVirt 4.0
Comment 29 Sandro Bonazzola 2016-07-05 03:38:06 EDT
oVirt 4.0.0 has been released, closing current release.

Note You need to log in before you can comment on or make changes to this bug.