Bug 1304729 - Hovering above an exclamation mark next to vm icon does not produce the expected message
Hovering above an exclamation mark next to vm icon does not produce the expec...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.3
Unspecified Unspecified
high Severity unspecified (vote)
: ovirt-3.6.5
: 3.6.5
Assigned To: Greg Sheremeta
Pavel Novotny
:
: 1304730 1305539 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 08:26 EST by sefi litmanovich
Modified: 2016-07-19 06:03 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-21 10:41:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tjelinek: ovirt‑3.6.z?
rule-engine: planning_ack?
oourfali: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)
VM info tooltip - exclamation mark (40.94 KB, image/png)
2016-04-05 13:02 EDT, Pavel Novotny
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 54841 master MERGED userportal, webadmin: fix vm status tooltip w/ alerts 2016-03-18 11:11 EDT
oVirt gerrit 54943 ovirt-engine-3.6 MERGED userportal, webadmin: fix vm status tooltip w/ alerts 2016-03-21 17:13 EDT

  None (edit)
Description sefi litmanovich 2016-02-04 08:26:17 EST
Description of problem:

Upon some problematic state or configuration of a vm, an exclamation mark appears next to a VM symbol in webadmin-> Virtual Machines tab, and hovering above it should present the user with the relevant message.
e.g. If there's a difference between the Timezone configuration of the vm in the system and the actual timezone of the vm, than the following message should appears when hovering mouse above the exclamation mark:
"Actual timezone in the guest differs from the configuration".
Right now no message appear with the exclamation mark, this was tried with different causes for this behaviour (1 - the above example, 2- difference between VM's actual OS and the OS configured in rhevm).

Version-Release number of selected component (if applicable):
rhevm-3.6.3-0.1.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. Create a vm and install some RHEL OS on it.
2. Set the VM os in rhevm to some windows version and restart the vm.
3. An exclamation mark appears next to the vm icon - hover the mouse above it.

Actual results:
Nothing happens, no message is seen.

Expected results:
The following message should appears in this case:
"Actual operating system type differs from the configuration"
Comment 1 sefi litmanovich 2016-02-04 10:29:19 EST
*** Bug 1304730 has been marked as a duplicate of this bug. ***
Comment 2 Tomas Jelinek 2016-02-11 06:40:54 EST
It seems this regression has been caused by:

https://gerrit.ovirt.org/#/c/48566/2/frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/widget/table/cell/VmStatusCell.java

Assigning to UX for investigation why has this change been introduced
Comment 3 Red Hat Bugzilla Rules Engine 2016-02-11 06:40:55 EST
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.
Comment 4 Greg Sheremeta 2016-02-11 20:45:24 EST
My bad, it looked like dead code to me. I'll fix.
Comment 5 Greg Sheremeta 2016-03-16 13:43:40 EDT
*** Bug 1305539 has been marked as a duplicate of this bug. ***
Comment 13 Pavel Novotny 2016-04-05 13:01:23 EDT
Verified in rhevm-webadmin-portal-3.6.5-0.1.el6.noarch

Verification steps:
1. Have a running VM with RHEL7 OS installed (guest agent too) and time zone set to GMT+2.
2. Shut down the VM and change OS type to Windows 7 x64 and Time Zone to GMT.
3. Start the VM again.

Results: exclamaion mark appears next to VM status icon, hovering over it shows a tooltip:
"""
Up

Actual timezone in the guest differs...

Actual operating system type differs...
"""

See attached screenshot for details.

The amount of text isn't honestly optimal for the small tooltip, but for now I guess it's better than no information at all.
Comment 14 Pavel Novotny 2016-04-05 13:02 EDT
Created attachment 1143897 [details]
VM info tooltip - exclamation mark

Note You need to log in before you can comment on or make changes to this bug.