Bug 1273988 - BigApp: Data Correction human task is not generated
BigApp: Data Correction human task is not generated
Status: CLOSED NOTABUG
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.2.0
x86_64 All
high Severity urgent
: ---
: ---
Assigned To: Kris Verlaenen
Pavel Kralik
:
Depends On: 1270690
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-21 12:34 EDT by Pavel Kralik
Modified: 2015-10-29 10:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-29 10:51:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
BigApp process model (109.70 KB, image/png)
2015-10-23 11:14 EDT, Pavel Kralik
no flags Details
BPMS/EAP bind to 0.0.0.0 server.log (184.75 KB, text/plain)
2015-10-29 05:55 EDT, Pavel Kralik
no flags Details

  None (edit)
Description Pavel Kralik 2015-10-21 12:34:23 EDT
Description of problem:
When mortgage demo is tested with amortization 28 years, there should be generated correction task human task, but there is not. Server log is clean.

Data:
//Test data from babak's video; Amortization 28 intentionally incorrect to test Data Correction HT
        {"Babak Mozaffari", "12300 Wilshire Blvd., Los Angele, CA", "333224444", "200000", "1000000", "200000", "28"},

Version-Release number of selected component (if applicable):
BPMS 6.2.0.ER4

How reproducible:
Always

Steps to Reproduce:
1. Install mortgage demo
2. Start instance with data above
3. There is no correction HT

Actual results:
No Human Task generated

Expected results:
Correction HT in Task List

Additional info:
Comment 2 Kris Verlaenen 2015-10-22 09:10:18 EDT
Pavel,

I installed 6.2.0.ER4 on top op EAP 6.4.3 and could not reproduce the issue, the data correction task was created successfully.

Could you check the following:
 - At which node is the process instance in your case (you can check details in the process instance list)?  If you for example didn't deploy the web service, it might be stuck elsewhere.
 - Does your user have the 'broker' role? Otherwise the task will not show up on his task list.
 - Try refreshing the task list after navigating to it, there is a known issue in ER4 that introduces a refresh issue when you switch to the task list perspective.
Comment 3 Pavel Kralik 2015-10-23 08:50:36 EDT
Hi Kris,
I added depends on BZ1270690. Tried to reproduce with fresh installation 6.2.0.ER4/EAP 6.4.3 too. It seems that it is refreshing problem. I want to check it again in ER5/CR1.
Comment 4 Pavel Kralik 2015-10-23 11:12:38 EDT
When 6.2.0.ER4/EAP 6.4.3 is started as:
bin/standalone.sh
and BigApp is deployed it works as desired.

When 6.2.0.ER4/EAP 6.4.3 started as:
bin/standalone.sh -b 0.0.0.0
with BigApp deployed, the Data Correction HT is generated and after correction a completing is stuck in Troubleshoot HT. No "Appraisal" HT.
Comment 5 Pavel Kralik 2015-10-23 11:14 EDT
Created attachment 1085860 [details]
BigApp process model
Comment 6 Pavel Kralik 2015-10-23 12:08:19 EDT
18:06:49,691 INFO  [stdout] (http-/0.0.0.0:8080-8) Application valid, will call credit service: Application [validationErrors=null, apr=null, mortgageAmount=800000, applicant=Applicant [creditScore=null, income=200000, name=Babak Mozaffari, ssn=333224444], amortization=30, downPayment=200000, property=Property [price=1000000, address=12300 Wilshire Blvd., Los Angele, CA], appraisal=null]
18:06:50,386 INFO  [org.apache.cxf.endpoint.dynamic.DynamicClientFactory] (http-/0.0.0.0:8080-8) Created classes: com.redhat.bpms.examples.mortgage.GetCreditScore, com.redhat.bpms.examples.mortgage.GetCreditScoreResponse, com.redhat.bpms.examples.mortgage.ObjectFactory
18:06:54,038 WARNING [org.apache.cxf.phase.PhaseInterceptorChain] (http-/0.0.0.0:8080-8) Interceptor for {http://mortgage.examples.bpms.redhat.com/}CreditServiceService#{http://mortgage.examples.bpms.redhat.com/}getCreditScore has thrown exception, unwinding now: org.apache.cxf.interceptor.Fault: Could not send Message.
...
Caused by: java.net.NoRouteToHostException: No route to host
Comment 9 Pavel Kralik 2015-10-29 05:55 EDT
Created attachment 1087437 [details]
BPMS/EAP bind to 0.0.0.0 server.log
Comment 10 Pavel Kralik 2015-10-29 10:51:04 EDT
According to the latest available documentation BigApp should be run with localhost only. Closing as NOTABUG.

https://access.redhat.com/documentation/en-US/Red_Hat_JBoss_BPM_Suite/6.0/html-single/Working_with_the_BPM_Suite_Example_App/

Note You need to log in before you can comment on or make changes to this bug.