This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1274058 - sysfsutils and sg3_utils missing from dependency list of openstack-nova
sysfsutils and sg3_utils missing from dependency list of openstack-nova
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
6.0 (Juno)
Unspecified Unspecified
medium Severity medium
: z4
: 7.0 (Kilo)
Assigned To: Lee Yarwood
nlevinki
: Triaged, ZStream
: 1288141 (view as bug list)
Depends On: 1288137
Blocks: 1288138 1288139
  Show dependency treegraph
 
Reported: 2015-10-21 15:16 EDT by David Hill
Modified: 2016-01-12 15:58 EST (History)
15 users (show)

See Also:
Fixed In Version: openstack-nova-2015.1.2-8.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1288137 1288138 (view as bug list)
Environment:
Last Closed: 2016-01-12 15:42:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Hill 2015-10-21 15:16:36 EDT
Description of problem:
When trying to delete a 3PAR volume, sginfo is called from nova but is not installed.   sg3_utils must be manually installed.  Would it be possible to add it has a package dependency in openstack-nova?
 
Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Attach a volume
2. Try to detach it
3.

Actual results:
Wont detach because sginfo is missing

Expected results:
Should detach

Additional info:
Comment 4 Lee Yarwood 2015-12-03 11:33:53 EST
*** Bug 1288141 has been marked as a duplicate of this bug. ***
Comment 6 Alan Pevec 2015-12-03 13:11:51 EST
While at it, please check if all binaries in rootwrap filters are covered by Requires: in spec.
Comment 8 Lee Yarwood 2015-12-11 12:37:27 EST
(In reply to Alan Pevec from comment #6)
> While at it, please check if all binaries in rootwrap filters are covered by
> Requires: in spec.

Thanks Alan, just to document in the bug that this has been done in the change below.

Add dependencies for sg3_utils and sysfsutils to nova-compute
https://review.gerrithub.io/#/c/254215/
Comment 11 Lon Hohberger 2016-01-12 15:42:16 EST
openstack-nova-2015.1.2-13.el7ost, which has already been shipped live, contains a fix for this issue.

Note You need to log in before you can comment on or make changes to this bug.