Bug 1274158 - [RFE][PRD] Collect keypairs of all the users within a tenant or multiple tenant
[RFE][PRD] Collect keypairs of all the users within a tenant or multiple tenant
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.4.0
Unspecified Unspecified
high Severity high
: GA
: cfme-future
Assigned To: John Hardy
Ola Pavlenko
tenant:openstack:cloud:prd
: FutureFeature
Depends On: 1211987
Blocks: 1511957
  Show dependency treegraph
 
Reported: 2015-10-22 03:18 EDT by Prasad Mukhedkar
Modified: 2018-05-21 04:45 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-01-11 13:03:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: Openstack


Attachments (Terms of Use)

  None (edit)
Description Prasad Mukhedkar 2015-10-22 03:18:28 EDT
Cloudforms currently collects keypairs created by  the admin user (the same CloudForms use). It doesnt collect keypairs those are created by normal users.

It is important to allow users to create their own keys on OpenStack and use them on CloudForms.

Example : 

Projects : tenant1, tenant2, tenant3,tenant4
Users : cfmeadmin (admin for all four above projects/tenants ) and user1 (member of tenant1)

create a keypair by login as "user1" in tenant1 and one more keypair created by login as "cfmeadmin".
---

Add this opemstack env to cloudforms and the evm refresh. 

Being a cfmeadmin as admin user for all above four tenants, Ideally it should see all the keypairs created in these tenant irrespective of which user and how but but it lists only one keypair that is created by himself.
Comment 4 Greg Blomquist 2016-02-19 10:01:01 EST
@Ladas, looks like they added this feature in OSP.

Can you give an estimate of implementation for our OSP integration?
Comment 5 Greg Blomquist 2016-02-19 10:03:15 EST
John, where does this fit in with priorities?

Also, reassigning to Mainn for OSP integration.
Comment 6 Tzu-Mainn Chen 2016-02-19 10:22:06 EST
Re-assigning the Marek.
Comment 7 John Hardy 2016-07-28 09:46:57 EDT
Please confirm this is delivered in CF 4.2 thanks
Comment 9 Marek Aufart 2016-11-23 04:37:20 EST
The Openstack spec mentioned in comment #3 requires user_id, which is Openstack User that is not modelled in CF at this moment. I expected that it will be part of an Impersonation feature in future.

If this would become blocker before modelling Openstack User, we can list Openstack users, collect their ids without saving and use it to query key pairs. Then this BZ could be resolved.

Note You need to log in before you can comment on or make changes to this bug.