Bug 127431 - Mouse becomes erratic using KVM to change computers
Mouse becomes erratic using KVM to change computers
Status: CLOSED DUPLICATE of bug 111161
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Depends On:
  Show dependency treegraph
Reported: 2004-07-07 23:19 EDT by Rick Stewart
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:04:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Rick Stewart 2004-07-07 23:19:41 EDT
Description of problem:
When using KVM (2 Belkin OmniPro 4-Ports Cabled). When switching to 
desktop from another computer the mouse (MS Intellimouse Explorer) 
becomes erratic;

movement is erratic bears no resemblance to mouse movement
get left and right mouse clicks without touching buttons

when I log out and then switch computers mouse is stable on return.

This happens on the 2 machines I am running RHFC on. (600 Mhz Dell, 
2.8 Mhz Clone)

Sometimes see this on switch from GUI to Terminal to Gui.

If you need anything else please let me know.

Rick Stewart

Version-Release number of selected component (if applicable):
Red Hat Fedora Core 2 Download Gnome desktop

How reproducible:
Happens every time

Steps to Reproduce:
1.open desktop
2.switch to another computer
3.switch back. Bingo erratic
Actual results:
erratic mouse not erotic (spelling and an evil mind)

Expected results:
stabile mouse

Additional info:
Have done reinstalls and changed mouse types but it still continues.
Have also downloaded all fixes, but no change
Comment 1 Malcolm McMahon 2004-07-23 06:18:33 EDT
I've got this too, in spades, on a two way belkin KVM switch. I wonder
if the process of reading mouse packets gets out of phase with the
mouse. There ought to be a timeout on mouse packet completion.
Comment 2 Brian "netdragon" Bober 2004-09-07 11:46:43 EDT
This is not an X issue because X uses the kernel driver now. Dupe of
bug 111161? See also: http://bugzilla.kernel.org/show_bug.cgi?id=2082
Comment 3 Kristian Høgsberg 2004-09-14 22:00:27 EDT
*** Bug 128038 has been marked as a duplicate of this bug. ***
Comment 4 Kristian Høgsberg 2004-09-14 22:05:08 EDT
This is most likely a problem with the kernel input layer.  Some of
the synchronization problems were fixed recently, could you guys try
out the latest fc2 kernel update and see if that fixes the problem?

Comment 5 Rick Stewart 2004-09-14 23:12:47 EDT
Am presently using kernel 2.6.8-1.521smp and still have the same 

Have also tried the 2.6.8-1.521 problem is still there.

Is there a newer version


Comment 6 Brian "netdragon" Bober 2004-09-15 00:38:36 EDT
See https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=111161#c25
for the solution.
Comment 7 Mike A. Harris 2004-09-15 01:27:33 EDT

*** This bug has been marked as a duplicate of 111161 ***
Comment 8 Red Hat Bugzilla 2006-02-21 14:04:21 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.