Bug 128038 - Using Belkin switch box causes mouse confustion
Using Belkin switch box causes mouse confustion
Status: CLOSED DUPLICATE of bug 111161
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2004-07-16 12:53 EDT by Sean Bruno
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:04:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Sean Bruno 2004-07-16 12:53:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
If I have an FC2 box on a belkin KVM, switching from to a different
port causes the mouse to behave erratically.

In FC1, bouncing to a console(CTRL-ALT-F1) and back to X(CTRL-ALT-F7)
resolved my mouse issues.

But, now I have to physically disconeect the PS2 mouse from the belkin
KVM and reonnect it to get the mouse to work correctly.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.  Connect an FC2 box to any Belkin KVM
2.  Switch off of your FC2 box and Back again
3.  Mouse behaves erratically until you disconnect/reconnect your PS2

Actual Results:  The mouse will bounce all over the screen when moved.

Expected Results:  Mouse behaves normally

Additional info:

I am using an MS Wheel Mouse with the Belkin.  When I reonnect the
mouse to get it to work again, the wheel-up acts like a "right-click"
until I reboot, but this is minor compared to the behaviour when I
switch between ports
Comment 1 Terje Bless 2004-09-11 07:24:45 EDT
Duplicate of Bug #127431?
Comment 2 Kristian Høgsberg 2004-09-14 22:00:19 EDT
Yes, looks like bug #127431.  Please try a more recent kernel, as some
of these synchronization bugs have been fixed lately.

*** This bug has been marked as a duplicate of 127431 ***
Comment 3 Mike A. Harris 2004-09-15 01:27:10 EDT

*** This bug has been marked as a duplicate of 111161 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:04:28 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.