Bug 1274356 - Remote-viewer crash after login to VM
Remote-viewer crash after login to VM
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libgovirt (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity urgent
: rc
: ---
Assigned To: Christophe Fergeau
SPICE QE bug list
spice
: ZStream
Depends On: 1273977
Blocks: 1296687
  Show dependency treegraph
 
Reported: 2015-10-22 10:45 EDT by Fabiano Fidêncio
Modified: 2016-11-03 21:11 EDT (History)
20 users (show)

See Also:
Fixed In Version: libgovirt-0.3.3-2.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1273977
: 1296687 (view as bug list)
Environment:
Last Closed: 2016-11-03 21:11:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 David Blechter 2015-10-26 16:02:05 EDT
propose 7.2.z as customers can hit this issue
Comment 6 Christophe Fergeau 2016-01-05 08:45:55 EST
This bug is happening because the are 2 storage domains in the RHEV setup, and they both have the same name ('iso'). This triggers an untested code path in libgovirt, where some memory corruption happens.
This could not happen with rhev 3.5 or older as the foreign menu code was not used (if I'm not mistaken).
I have no idea how likely it is that customers will have storage domains with the same names (but the same crash woulod occur with VMs with the same names too).
However, given that the fix is small, better be safe than sorry and make a zstream update for that. While we should make sure the zstream is released around the same time as 3.6 GA, I'm not sure this should be marked as a blocker as it only happens on some setups.
Comment 8 Christophe Fergeau 2016-01-08 07:48:24 EST
Patch has been pushed to dist-git, no build done yet.
Comment 9 Mike McCune 2016-03-28 18:23:55 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 17 errata-xmlrpc 2016-11-03 21:11:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2229.html

Note You need to log in before you can comment on or make changes to this bug.