Bug 127444 - Can't rename shortcut created from mozilla
Can't rename shortcut created from mozilla
Status: CLOSED DUPLICATE of bug 125104
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
i586 Linux
medium Severity low
: ---
: ---
Assigned To: Alexander Larsson
Depends On:
  Show dependency treegraph
Reported: 2004-07-08 06:47 EDT by Sitsofe Wheeler
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:04:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Sitsofe Wheeler 2004-07-08 06:47:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.6)
Gecko/20040518 Firefox/0.8

Description of problem:
After dragging a picture from mozilla to the desktop the resulting
shortcut cannot be renamed.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Go to http://fedora.redhat.com/ in mozilla
2. Drag the picture of monitor and CDs (next to "What is The Fedora
Project?") to the desktop creating a shortcut called
intro-computer.png (the fact the shortcut doesn't work is already
covered by bug 126279)
3. Press the right mouse button over the intro-computer.png and go to
4. Part of the name should now be highlighted. Rename that part to test

Actual Results:
Icon remains named intro-computer.png

Expected Results:
Icon to be named test.png
Comment 1 Alexander Larsson 2004-08-26 09:45:57 EDT
Renames of desktop files change the name as listed in the desktop
file, since this is what is used to display the name of the icon in
the UI. Unfortunately this makes it hard to rename the file to
something else so its detected as a desktop file link...
Comment 2 Sitsofe Wheeler 2004-08-28 13:57:26 EDT
I'm afraid I don't quite follow. If it (the desktop file) is correctly
detected as a desktop file, and changing the approrpiate part of the
contents of the file changes its name, what is the problem?

Is the problem because when I dragged and dropped a link and a desktop
file were created? If so, why wasn't the link followed when a rename
was attempted and the contents of what the link was pointing to
changed? Is this undersirable because other desktop file names would
change at the same time?

Is the case that the act of a renaming actually generates a link
rather than changing the contents (but since it's the contents that
determines the name it appears there is no change)?

Sorry to ask so many questions, I'm just finding it tough to keep up
here at the back :)
Comment 3 Alexander Larsson 2004-09-02 08:09:33 EDT
I'm not sure exactly why it doesn't work, but its related to the real
filename extension being .png, the file type being a desktop file, and
renaming file types edits the contents instead of changing the filename.
Comment 4 Alexander Larsson 2004-10-05 09:07:42 EDT
This is a duplicate of bug 125104

*** This bug has been marked as a duplicate of 125104 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:04:21 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.