Bug 1274463 - Need updated at-spi2-atk package for GTK3 testing
Need updated at-spi2-atk package for GTK3 testing
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: at-spi2-atk (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Rui Matos
Desktop QE
: Rebase, TestBlocker
: 1368649 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2015-10-22 14:58 EDT by Sean Toner
Modified: 2016-11-03 21:48 EDT (History)
6 users (show)

See Also:
Fixed In Version: at-spi2-atk-2.14.1-1.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2016-11-03 21:48:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Sean Toner 2015-10-22 14:58:53 EDT
Description of problem:

Please see https://bugzilla.redhat.com/show_bug.cgi?id=1274453

For subscription-manager-gui testing, we use a test tool called ldtp which uses pyatspi and the accessibility tool kit for automation testing.  The at-spi2-atk package is a dependency for the high-level pyatspi package.

The version of at-spi2-atk that exists in RHEL-7.2 is at-spi2-atk-2.8.1-4.el7.x86_64 is about 3 years old and it is not current enough to support testing of certain GTK3 widgets (for example drop down boxes, spinner buttons, or key event presses).  This is causing a rather large portion of our automated tests to no longer work because of the GTK3 changes.

I have built the src.rpms from Fedora23 Beta on RHEL 7.2 and was able to get several GTK3 tests to work.  The version I built which works is 

[root@dhcp129-94 ~]# rpm -qa | grep at-spi2-atk

Version-Release number of selected component (if applicable):


How reproducible:


Additional info:

There are 3 other packages which simultaneously need to be updated for our testing needs:

atk  # a dependency of at-spi2-atk
Comment 1 Sean Toner 2015-10-22 15:01:51 EDT
Note that if you update at-spi2-atk to 2.17.90 (or greater), the current version of the atk package on RHEL 7.2 is too old (atk-2.14.0-1.el7.x86_64)

at-spi2-atk >= 2.17.90 requires that the atk version must be >= 2.15.4

Therefore updating the at-spi2-atk package will also require updating the atk package.
Comment 8 Rui Matos 2016-08-22 07:45:13 EDT
*** Bug 1368649 has been marked as a duplicate of this bug. ***
Comment 9 Bohdan Milar 2016-09-08 09:00:19 EDT
at-spi2-atk autotests pass:
Comment 11 errata-xmlrpc 2016-11-03 21:48:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.