Bug 1274709 - multiple commands merged together in qpid plugin
multiple commands merged together in qpid plugin
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sos (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Pavel Moravec
Miroslav Hradílek
:
Depends On:
Blocks: 1295396
  Show dependency treegraph
 
Reported: 2015-10-23 08:14 EDT by Martin Frodl
Modified: 2016-11-04 00:55 EDT (History)
8 users (show)

See Also:
Fixed In Version: sos-3.3-0.el7
Doc Type: Bug Fix
Doc Text:
Prior to this update, the qpid plug-in for the sos utility had a typo in invoking several commands, and the commands outputs were not collected. With this update, the typo is fixed, and the commands are properly invoked and their output collected.
Story Points: ---
Clone Of:
: 1274710 (view as bug list)
Environment:
Last Closed: 2016-11-04 00:55:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Frodl 2015-10-23 08:14:35 EDT
Description of problem:

sosreport's qpid plugin attempts to collect the output of the following monster command:

$ sosreport -o qpid --batch -v
...
[plugin:qpid] added cmd output 'qpid-config exchangesqpid-config queuesqpid-config exchanges -b'
...
[plugin:qpid] collecting output of 'qpid-config exchangesqpid-config queuesqpid-config exchanges -b'
...

This is due to missing commas at the end of the lines containing "qpid-config exchanges" and "qpid-config queues" in the plugin code:

        self.add_cmd_output([
            ...
            "qpid-stat -m",  # applies since 0.18 version
            "qpid-config exchanges"
            "qpid-config queues"
            "qpid-config exchanges -b",  # applies to pre-0.18 versions
            ...
        ])

Without the commas, Python's string literal concatenation feature [0] is applied to the strings, merging them into a single one.

Version-Release number of selected component (if applicable):
sos-3.2-15.el7_1.8.noarch

[0] https://docs.python.org/2/reference/lexical_analysis.html#string-literal-concatenation
Comment 2 Pavel Moravec 2015-10-23 08:36:56 EDT
Fixed in upstream recently: https://github.com/sosreport/sos/commit/5e02bb46cc1cddf7ccba27ff05a8702e806ad30d
Comment 4 Mike McCune 2016-03-28 19:20:28 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 5 Pavel Moravec 2016-06-22 06:32:44 EDT
For QE:

if you would like to have a real system with qpid-cpp package installed (so you dont need to mock the commands), let me know. I know qpid-cpp very well and can prepare a system in a short time.
Comment 9 errata-xmlrpc 2016-11-04 00:55:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2380.html

Note You need to log in before you can comment on or make changes to this bug.