This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1274710 - multiple commands merged together in qpid plugin
multiple commands merged together in qpid plugin
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sos (Show other bugs)
6.7
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Shane Bradley
Martin Frodl
: Regression
Depends On:
Blocks: 1274384
  Show dependency treegraph
 
Reported: 2015-10-23 08:15 EDT by Martin Frodl
Modified: 2016-05-10 17:07 EDT (History)
9 users (show)

See Also:
Fixed In Version: sos-3.2-29.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1274709
Environment:
Last Closed: 2016-05-10 17:07:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Frodl 2015-10-23 08:15:55 EDT
+++ This bug was initially created as a clone of Bug #1274709 +++

Description of problem:

sosreport's qpid plugin attempts to collect the output of the following monster command:

$ sosreport -o qpid --batch -v
...
[plugin:qpid] added cmd output 'qpid-config exchangesqpid-config queuesqpid-config exchanges -b'
...
[plugin:qpid] collecting output of 'qpid-config exchangesqpid-config queuesqpid-config exchanges -b'
...

This is due to missing commas at the end of the lines containing "qpid-config exchanges" and "qpid-config queues" in the plugin code:

        self.add_cmd_output([
            ...
            "qpid-stat -m",  # applies since 0.18 version
            "qpid-config exchanges"
            "qpid-config queues"
            "qpid-config exchanges -b",  # applies to pre-0.18 versions
            ...
        ])

Without the commas, Python's string literal concatenation feature [0] is applied to the strings, merging them into a single one.

Version-Release number of selected component (if applicable):
sos-3.2-28.el6.noarch

[0] https://docs.python.org/2/reference/lexical_analysis.html#string-literal-concatenation
Comment 2 Pavel Moravec 2015-10-23 08:37:45 EDT
Fixed in upstream already:

https://github.com/sosreport/sos/commit/5e02bb46cc1cddf7ccba27ff05a8702e806ad30d
Comment 9 errata-xmlrpc 2016-05-10 17:07:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0819.html

Note You need to log in before you can comment on or make changes to this bug.