Bug 127475 - monitor selection in kickstart
monitor selection in kickstart
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks: 133260 FC4Target
  Show dependency treegraph
 
Reported: 2004-07-08 15:14 EDT by Thomas Gordon
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-08 18:02:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kickstart file with video specification (2.09 KB, text/plain)
2004-10-25 15:04 EDT, david d zuhn
no flags Details
the xorg.conf file generated by the kickstart file (2.65 KB, text/plain)
2004-10-25 15:06 EDT, david d zuhn
no flags Details

  None (edit)
Description Thomas Gordon 2004-07-08 15:14:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040518 Firefox/0.8

Description of problem:
unable to select desired monitor/resolution in kickstart

Version-Release number of selected component (if applicable):
anaconda-10.0.1-0.20040701220944

How reproducible:
Always

Steps to Reproduce:
1. use --monitor or --resolution with xconfig in kickstart
2. kickstart
3. boot
    

Actual Results:  probed monitor becomes setting and entries removed
from anaconda-ks.cfg

Expected Results:  specified monitor should be what is used

Additional info:

ks.cfg USED:

xconfig --card "ATI Radeon Mobility U1" --videoram 131072 --monitor
"LCD Panel 1280x800" --hsync 31.5-90.0 --vsync 60-60 --resolution
1280x800 --depth 24 --startxonboot --noprobe --defaultdesktop gnome

RESULTING anaconda-ks.cfg:

xconfig --card "ATI Radeon Mobility U1" --videoram 131072 --hsync
31.5-90.0 --vsync 60-60 --resolution 1920x1440 --depth 24
--startxonboot --defaultdesktop gnome
Comment 1 Jeremy Katz 2004-09-22 15:50:13 EDT
Does this still not work?
Comment 2 david d zuhn 2004-10-25 11:44:03 EDT
I have encountered this same problem, using FC3rc1. 

My kickstart file contains the following line:

xconfig --card "NVIDIA GeForce FX (generic)" --videoram 65536 --hsync
31.5-37.9 --vsync 50-70 --resolution 1280x960 --depth 24
--startxonboot  --defaultdesktop gnome

but when I run the installer, I end up with a configuration that
matches what's put into /root/anaconda-ks.cfg

xconfig --card "NVIDIA GeForce FX (generic)" --videoram 65536 --hsync
31.5-37.9 --vsync 50-70 --resolution 800x600 --depth 24 --startxonboot
 --defaultdesktop gnome

Comment 3 david d zuhn 2004-10-25 15:04:28 EDT
Created attachment 105740 [details]
kickstart file with video specification
Comment 4 david d zuhn 2004-10-25 15:06:02 EDT
Created attachment 105741 [details]
the xorg.conf file generated by the kickstart file

Note the modes line which doesn't match the resolution specified in the
kickstart file.  There was no firstboot run to offer a chance to fix this.
Comment 5 Jeremy Katz 2005-05-18 15:47:13 EDT
Is this better in FC4 test3?
Comment 6 Paul Nasrat 2005-05-24 11:40:18 EDT
Remove from FC3 tracker - were you able to test with FC4test3?
Comment 7 Jeremy Katz 2005-07-08 18:02:50 EDT
Closing due to inactivity.  Please reopen if you have further information to add
to this report.

Note You need to log in before you can comment on or make changes to this bug.