This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1274824 - [QE](6.2.z)"Complete" button in task view's table doesn't work [NEEDINFO]
[QE](6.2.z)"Complete" button in task view's table doesn't work
Status: CLOSED NOTABUG
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.2.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Mauricio Salatino
Lukáš Petrovický
:
Depends On:
Blocks: 1295500
  Show dependency treegraph
 
Reported: 2015-10-23 11:18 EDT by jvahala
Modified: 2016-04-28 01:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1295500 (view as bug list)
Environment:
Last Closed: 2016-01-07 11:11:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
kverlaen: needinfo? (jsniezek)


Attachments (Terms of Use)

  None (edit)
Description jvahala 2015-10-23 11:18:57 EDT
Description of problem:
in task view (when at least one task is started and assigned to user) the "complete" button in table does nothing. it should behave same as in "work" view. 

How reproducible:
always

Steps to Reproduce:
1. create business process with human task and assign it to user 
2. build and deploy
3. run process in process definitions
4. go to task view, try to complete it via "complete" button in table 

Actual results:
nothing happens

Expected results:
task should be completed
Comment 2 Kris Verlaenen 2016-01-05 07:48:09 EST
The complete button was never intended to actually complete the task.  The main reason is that completing a task like this will not associate any results with the task (bypassing the task form), which in general would introduce issues in the process as this is most likely depending on this.  The goal of the complete button was to jump to the task form so the task can be completed (by filling in the form and clicking complete).

The current implementation (checked with 6.2.0.GA) seems to be doing that, the "odd" behavior I could find was that if the details panel on the right is closed, clicking it will not reopen it, and if you click complete twice it will actually close the details panel.  It seems this behavior is simply the result of how the row selection works (the complete button is probably not doing anything special).

@Joe, any feedback on how this could be improved?  Should we simply remove the button altogether?
Comment 5 Kris Verlaenen 2016-01-07 11:11:55 EST
Closing this off, as button is working as expected.  Will address the "odd" behavior in a separate BZ:
https://bugzilla.redhat.com/show_bug.cgi?id=1296165

Note You need to log in before you can comment on or make changes to this bug.