Bug 1275155 - [Tier]: Typo in the output while setting the wrong value of low/hi watermark
Summary: [Tier]: Typo in the output while setting the wrong value of low/hi watermark
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: tier
Version: rhgs-3.1
Hardware: x86_64
OS: Linux
medium
low
Target Milestone: ---
: RHGS 3.1.2
Assignee: hari gowtham
QA Contact: Bhaskarakiran
URL:
Whiteboard:
Depends On:
Blocks: 1260783 1260923 1275502 1275910
TreeView+ depends on / blocked
 
Reported: 2015-10-26 07:18 UTC by Rahul Hinduja
Modified: 2016-11-23 23:12 UTC (History)
8 users (show)

Fixed In Version: glusterfs-3.7.5-5
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1275502 (view as bug list)
Environment:
Last Closed: 2016-03-01 05:44:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0193 0 normal SHIPPED_LIVE Red Hat Gluster Storage 3.1 update 2 2016-03-01 10:20:36 UTC

Description Rahul Hinduja 2015-10-26 07:18:56 UTC
Description of problem:
=======================

While setting the wrong value of watermark-hi/low the output shows "compatiblevalue" whereas it should be "compatible value"

Current:
========

[root@dhcp37-165 glusterfs]# gluster volume set tiervolume cluster.watermark-hi 100
volume set: failed: 100 is not a compatiblevalue. cluster.watermark-hi expects a percentage from 1-99.
[root@dhcp37-165 glusterfs]# gluster volume set tiervolume cluster.watermark-low 100
volume set: failed: 100 is not a compatiblevalue. cluster.watermark-low expects a percentage from 1-99.
[root@dhcp37-165 glusterfs]# 


Expected:
=========

[root@dhcp37-165 glusterfs]# gluster volume set tiervolume cluster.watermark-hi 100
volume set: failed: 100 is not a compatible value. cluster.watermark-hi expects a percentage from 1-99.
[root@dhcp37-165 glusterfs]# gluster volume set tiervolume cluster.watermark-low 100
volume set: failed: 100 is not a compatible value. cluster.watermark-low expects a percentage from 1-99.
[root@dhcp37-165 glusterfs]# 


Version-Release number of selected component (if applicable):
=============================================================
glusterfs-3.7.5-0.3.el7rhgs.x86_64


How reproducible:
=================
always

Comment 3 Bhaskarakiran 2015-11-02 06:45:49 UTC
Verified on 3.7.5-5 and is fixed.

[root@transformers ~]# gluster v set vol1 cluster.watermark-hi 100
volume set: failed: 100 is not a compatible value. cluster.watermark-hi expects a percentage from 1-99.
[root@transformers ~]# gluster v set vol1 cluster.watermark-low 100
volume set: failed: 100 is not a compatible value. cluster.watermark-low expects a percentage from 1-99.

Comment 5 errata-xmlrpc 2016-03-01 05:44:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html


Note You need to log in before you can comment on or make changes to this bug.