Bug 1275182 - [RFE]Email notification when the number of LVs in SD are reaching/more than 300
[RFE]Email notification when the number of LVs in SD are reaching/more than 300
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs (Show other bugs)
3.5.4
All Linux
medium Severity medium
: ovirt-4.0.0-rc
: 4.0.0
Assigned To: Idan Shaby
Natalie Gavrielov
: EasyFix, FutureFeature
Depends On: 1317468
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-26 04:45 EDT by Alexandros Gkesos
Modified: 2017-03-10 01:54 EST (History)
14 users (show)

See Also:
Fixed In Version: ovirt 4.0.0 alpha1
Doc Type: Enhancement
Doc Text:
Previously, when the number of logical volumes in a storage domain reached the recommended maximum it was logged and a message was shown in the events pane. Now, a user can register to the event notifier and receive an email when the number of logical volumes in a storage domain reached the recommended maximum.
Story Points: ---
Clone Of:
: 1317468 (view as bug list)
Environment:
Last Closed: 2016-08-23 16:30:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 53583 master MERGED engine: add event notification for number of LVs 2016-02-17 03:24 EST
oVirt gerrit 58639 master MERGED engine: prevent notification flood for number of LVs 2016-06-06 04:11 EDT
oVirt gerrit 58652 ovirt-engine-4.0 MERGED engine: prevent notification flood for number of LVs 2016-06-06 07:06 EDT

  None (edit)
Description Alexandros Gkesos 2015-10-26 04:45:08 EDT
Description of problem:

- We have the Logical Volumes limitation in a Storage Domain in our official Documentation

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.5/html/Technical_Guide/Storage_domain_limitations.html

- We have the warning at the RHEV-M events

"The number of LVs on the domain XXX exceeded 300, you are approaching the limit where performance may degrade."

But many customers do not access frequently the admin portal and do not get notified regarding that.

Feature Request:

Can we have an email notification for this as well?

Also it would be good to have in Storage Domain's "General" tab, the "Total number of LVs"
(without this, the admin will not know how many disks he has to move to another Storage Domain)*

Also. maybe a pop-up warning when the admin is trying to add one more disk/snapshot.*

*Let me know if we need separate RFEs for these
Comment 4 Allon Mureinik 2015-10-28 10:02:03 EDT
(In reply to Alexandros Gkesos from comment #0)
> Description of problem:
> 
> - We have the Logical Volumes limitation in a Storage Domain in our official
> Documentation
> 
> https://access.redhat.com/documentation/en-US/
> Red_Hat_Enterprise_Virtualization/3.5/html/Technical_Guide/
> Storage_domain_limitations.html
> 
> - We have the warning at the RHEV-M events
> 
> "The number of LVs on the domain XXX exceeded 300, you are approaching the
> limit where performance may degrade."
> 
> But many customers do not access frequently the admin portal and do not get
> notified regarding that.
Oved - don't we have a notifier mechanism that can send an email based on an event?
Comment 5 Alexandros Gkesos 2015-10-28 10:11:23 EDT
There is the engine-notifier, but there is no option yet for that event.

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.3/html-single/Administration_Guide/index.html#chap-Event_Notifications
Comment 6 Oved Ourfali 2015-10-28 10:19:35 EDT
There is a mechanism. 
It should be simple to add this event there.
 
Once you assign someone for that, have him sit with Moti, and he will give a proper example.
Comment 7 Allon Mureinik 2015-10-28 13:54:40 EDT
(In reply to Oved Ourfali from comment #6)
> There is a mechanism. 
> It should be simple to add this event there.
>  
> Once you assign someone for that, have him sit with Moti, and he will give a
> proper example.
Thanks Oved!
I was under the [wrong] impression that there's a generic connection between AuditLogs and notifications, and the customer just needs to set up the email details.

Once we start handling 4.0 features, I'll send someone your way.

Thanks again!
Comment 11 Natalie Gavrielov 2016-05-08 06:32:22 EDT
Hi Idan,

Is the 350 value hardcoded?
If not where can it be changed (DB / XML)?
Comment 12 Idan Shaby 2016-05-15 02:11:30 EDT
Hi Natalie,

Sorry for the delay, I was on PTO the past week.
The default number is 300 and it can be found on the DB:

engine=> SELECT * from vdc_options WHERE option_name = 'AlertOnNumberOfLVs';
 option_id |    option_name     | option_value | version 
-----------+--------------------+--------------+---------
       368 | AlertOnNumberOfLVs | 300          | general
Comment 13 Allon Mureinik 2016-05-22 09:55:59 EDT
(In reply to Idan Shaby from comment #12)
> Hi Natalie,
> 
> Sorry for the delay, I was on PTO the past week.
> The default number is 300 and it can be found on the DB:
> 
> engine=> SELECT * from vdc_options WHERE option_name = 'AlertOnNumberOfLVs';
>  option_id |    option_name     | option_value | version 
> -----------+--------------------+--------------+---------
>        368 | AlertOnNumberOfLVs | 300          | general

We can add this as a config value to engine-config.sh. It's a trivial patch - but I wonder whether we want to make this visible to our customers. Yaniv D - your two cents?
Comment 14 Yaniv Lavi 2016-05-22 10:03:35 EDT
(In reply to Allon Mureinik from comment #13)
> (In reply to Idan Shaby from comment #12)
> > Hi Natalie,
> > 
> > Sorry for the delay, I was on PTO the past week.
> > The default number is 300 and it can be found on the DB:
> > 
> > engine=> SELECT * from vdc_options WHERE option_name = 'AlertOnNumberOfLVs';
> >  option_id |    option_name     | option_value | version 
> > -----------+--------------------+--------------+---------
> >        368 | AlertOnNumberOfLVs | 300          | general
> 
> We can add this as a config value to engine-config.sh. It's a trivial patch
> - but I wonder whether we want to make this visible to our customers. Yaniv
> D - your two cents?

We should since for some storage we can have more and for some less. It's also a matter of how conservative the customer is. Users would like to change this.
Comment 15 Allon Mureinik 2016-05-22 12:47:28 EDT
(In reply to Yaniv Dary from comment #14)
> (In reply to Allon Mureinik from comment #13)
> > (In reply to Idan Shaby from comment #12)
> > > Hi Natalie,
> > > 
> > > Sorry for the delay, I was on PTO the past week.
> > > The default number is 300 and it can be found on the DB:
> > > 
> > > engine=> SELECT * from vdc_options WHERE option_name = 'AlertOnNumberOfLVs';
> > >  option_id |    option_name     | option_value | version 
> > > -----------+--------------------+--------------+---------
> > >        368 | AlertOnNumberOfLVs | 300          | general
> > 
> > We can add this as a config value to engine-config.sh. It's a trivial patch
> > - but I wonder whether we want to make this visible to our customers. Yaniv
> > D - your two cents?
> 
> We should since for some storage we can have more and for some less. It's
> also a matter of how conservative the customer is. Users would like to
> change this.

Ack.
I opened bug 1338545 to track this requirement.

QA: Note that for the context of THIS bug, having it available via engine-config.sh is just a nicety. THIS bug can be verified by querying (or even updating) the database directly.
Comment 16 Allon Mureinik 2016-06-07 04:03:41 EDT
Moving target release to RC to include the latest fix.
Comment 18 Natalie Gavrielov 2016-07-05 13:32:16 EDT
Verified, rhevm-4.0.0.5-0.1.el7ev.noarch
One issue found (in one of the earlier builds) :
https://bugzilla.redhat.com/show_bug.cgi?id=1340209
Comment 20 errata-xmlrpc 2016-08-23 16:30:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1743.html

Note You need to log in before you can comment on or make changes to this bug.